Using sync and filtering to recurse into subdirectories

What is the problem you are having with rclone?

Basically, I am wanting to run rclone sync across a directory that includes subdirectories and recurse through to the subdirectories. I have set up similar directory structure on destination that is on the source. I can do it one subdirectory at a time, but would prefer to not do this.

I know I have to use filtering, but I am not doing something right there. As I understand, if I run --include '/**', the command should recurse, but this does not happen.

Run the command 'rclone version' and share the full output of the command.

rclone v1.59.1

  • os/version: darwin 12.5.1 (64 bit)

  • os/kernel: 21.6.0 (x86_64)

  • os/type: darwin

  • os/arch: amd64

  • go/version: go1.18.5

  • go/linking: dynamic

  • go/tags: cmount

Which cloud storage system are you using? (eg Google Drive)

Dropbox

The command you were trying to run (eg rclone copy /tmp remote:tmp)

rclone lsd Dropbox: --include "/**"

The rclone config contents with secrets removed.

Paste config here

A log from the command with the -vv flag

2022/09/10 12:42:32 DEBUG : rclone: Version "v1.59.1" starting with parameters ["rclone" "lsd" "Dropbox:" "--include" "/**" "-vv"]
2022/09/10 12:42:32 DEBUG : Creating backend with remote "Dropbox:"
2022/09/10 12:42:32 DEBUG : Using config file from "/Users/me/.config/rclone/rclone.conf"
          -1 2022-09-10 12:42:32        -1 Dir1
          -1 2022-09-10 12:42:32        -1 Dir2
2022/09/10 12:42:32 DEBUG : 7 go routines active
2022/09/10 12:42:32 INFO  : Dropbox root '': Commiting uploads - please wait...

What I'm wanting to do is to get the files that are in Dir2 rclone synched w/my external destination drive.

If all you're trying to do is to recurse the lsd command then the way I've done it is by using the "--max-depth 0" option.

Something like: rclone lsd --max-depth 0 Dropbox: