Using rclone with Nextcloud and self-signed certificate

Hi, community!

I'm trying to connect rclone to my Nextcloud instance using a self-signed certificate, but get the following error:

Failed to create file system for "Nextcloud:/Nextcloud": read metadata failed: Propfind https://XXX.XX.XXX.XX/remote.php/webdav/Nextcloud: x509: cannot validate certificate for XXX.XX.XXX.XX because it doesn't contain any IP SANs

I have the .crt file copied to /etc/ca-certificates/trust-source/anchors and run the sudo update-ca-trust command (I'm on Arch Linux), but still get the above error.

I can, of course, run rclone with the --no-check-certificate flag (it works, by the way), but I guess this is not recommended.

I think you can do one of two things:

  • Use the no check certificate since it's self signed

or you can use the flags:

  --ca-cert string         CA certificate used to verify servers
  --client-cert string     Client SSL certificate (PEM) for mutual TLS auth
  --client-key string      Client SSL private key (PEM) for mutual TLS auth

I think both work.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.