Using rclone for Cloud to Cloud Transfer

What is the problem you are having with rclone?

I am trying to run rclone on the server, for a cloud to cloud transfer.

First i am just trying to run a ls and lsd command using the rclone program installed on desktop computer.
This command work very well on my desktop computer

The command from desktop computer, just testing ls and lsd

MacBookPro-2018:~ tormod$ rclone lsd pcloud:
          -1 2021-05-31 23:14:57        -1 .TemporaryItems
          -1 2021-02-28 21:24:54        -1 Automatic Upload
          -1 2021-05-18 16:39:30        -1 Bank
          -1 2021-06-11 18:24:46        -1 Båt
          -1 2021-06-11 18:38:55        -1 Bil
          -1 2021-03-04 20:07:00        -1 Bilde
          -1 2021-06-11 17:48:56        -1 Data
          -1 2018-10-21 22:21:12        -1 Diskstation
          -1 2021-06-11 18:37:22        -1 Econosto
          -1 2017-09-18 23:34:20        -1 Elektro

rclone version for desktop computer :

MacBookPro-2018:~ tormod$ rclone -V
rclone v1.55.1
- os/type: darwin
- os/arch: amd64
- go/version: go1.16.3
- go/linking: dynamic
- go/tags: cmount

So, this is a listing of the directories on the pcloud account.
Everything ok so far.

rclone version on

MacBookPro-2018:rclone tormod$ ssh rclone -V
rclone v1.52.2
- os/arch: freebsd/amd64
- go version: go1.15.2
MacBookPro-2018:rclone tormod$ 

I have a normal account ( not the restricted borg account )

Cloud storage system :


lsd command from server

ssh rclone -vv lsd pcloud:

The rclone config contents with secrets removed.

type = pcloud
hostname =
token = {"access_token":"XXXX","token_type":"bearer","expiry":"0001-01-01T00:00:00Z"}

A log from the command with the -vv flag

2021/06/28 21:29:59 DEBUG : rclone: Version "v1.52.2" starting with parameters ["/usr/local/bin/rclone" "-vv" "lsd" "pcloud:"]
2021/06/28 21:29:59 DEBUG : Using config file from "/data1/home/XXXX/.config/rclone/rclone.conf"
2021/06/28 21:30:00 ERROR : : error listing: couldn't list files: pcloud error: Invalid 'access_token' provided. (2094)
2021/06/28 21:30:00 DEBUG : 3 go routines active
2021/06/28 21:30:00 Failed to lsd with 2 errors: last error was: couldn't list files: pcloud error: Invalid 'access_token' provided. (2094)  log here

So, this is not working. I have tried to copy the config file from desktop computer to , but no change. Have tried the

ssh rclone config

several times. No change

I am following this recipe :

and this one

and this one

Have contacted the , but they do not know
"what could be causing it nor have we heard of any issues using pCloud"

hello and welcome to the forum,

the rclone version for is over one year old.
there were some issues with, that was fixed in v1.52.3.

so please update and test again.

Hi there, jojothehumanmonkey !

I sent an e-mail to, and they have updated the rclone version on the server.
It is now working.
I have only tested the lsd command, now it does not return an error message.

Thanks, and best regards

Tormod Willassen

glad we got it working....

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.