Use High Sierra with Google Drive File Stream + rclone MOUNT?

Has anyone successfully used Google File Stream for the files and then rclone mount off what is visible in Google File Stream?

Previously, I have used rclone to upload encrypted data to my Google Drive. With GDrive file stream, I can now see that folder as another drive on my Mac, but obviously the contents are encrypted.

Is there a way to point rclone to this new drive+folder and say, “Decrypt this, please, so that I may see the real contents and stream them in real time?”

It’s really weird, I can use rclone mount for a normal google drive, and rclone mount for a crypt on google drive. For either of those options, the mount is successful and I can see the files in Finder.

But when I try to rclone mount a crypt on google drive using file stream, I get nothing. I tried using a symlink to /Volumes/GoogleDrive/My\ Drive/Encrypted/ (literally just typing rclone mount googlecrypt: /Users/ABC/rclonecryptmount ), it mounts but I don’t see anything at all in Finder. But I DO see the files in terminal. Very odd and I’m having a hard time trying to trouble shoot it.

Would love to hear your experience if you managed to use rclone mount from a crypt on File Stream?

WHY am I trying to do this? Why file stream instead of rclone mount directly? rclone mount is definitely slower than file stream since file stream has all the caching going on. So rclone can then use those cached results from file stream and at least show me the decrypted file names. I prefer to use file stream and then have rclone mount from file stream.

Not sure it it will do what you are hoping for, but

I am assuming you already have an crypt config that you use for uploading, that should have 2 passwords in it, you will need those to apply to the new config below.

so if you create a new config in your rclone config file, something like this:

type = crypt
remote = /Volumes/GoogleDrive/My Drive/path/to/encrypted/folder
filename_encryption = standard
password = yourpassword
password2 = youpassword2

Then you should be able to mount it with something like this:

rclone mount --read-only --allow-other filestreamEnc: /path/to/a/directory/to/mount &

and access the files in here.

I just did that and can see the decrypted content in the finder.

(But this was on Sierra, not High Sierra)

When trying to mount i get:

Fatal error: failed to mount FUSE fs: exit status 2

(I’m on High Sierra)

Are you having trouble making rclone mount work at all? Make sure you’ve got OSXFUSE installed properly. If that doesn’t do it then maybe you should make a new forum topic with more info.

Solved! the --allow-other flag seemed to be the key here. Also mounting directly as you said:

remote = /Volumes/GoogleDrive/My Drive/path/to/encrypted/folder

doesn’t work for me. I need to create a symlink and make it

remote = /Users/ABC/Desktop/filestream

and then that points to /Volumes/GoogleDrive/My Drive/path/to/encrypted/folder

If I try it directly in rclone config file, it mounts but doesn’t show anything in Terminal or Finder.

@ncw I wonder if this is some sort of config bug?

EDIT: Also, copying files into this rclone mounted symlink on file stream causes all sorts of issues. In short, I get file not found errors. It seems like I am unable to transfer files into my rclone crypt that is mounted through file stream.

Not sure! I think it might be OSX security at plan.

Hmm, that is probably because of rclone’s somewhat limited mount, it can only read OR write files, not do both at once.

Sorry to resurrect this old thread. I am a little confused as have been testing more. If I rclone mount a crypt that is on Google Drive directly, I can successfully copy/paste files directly into the mounted crypt through MacOS Finder. This shows me that it is possible to mount a rclone crypt and then write files to it using the OS GUI rather than using the rclone copy/rclone move commands. The rclone mount is not read only.

So why would this be any different when using Google Drive File Stream? If I try to paste any files into that mount, I get the following error:

The Finder can’t complete the operation because some data in “test.txt” can’t be read or written.
(Error code -36)

and I also get the following rclone error:

2017/11/12 17:37:19 ERROR : test/test.png: WriteFileHandle.New Rcat failed: corrupted on transfer
2017/11/12 17:37:19 ERROR : test/test.png: WriteFileHandle.Release error: corrupted on transfer
2017/11/12 17:37:19 ERROR : test/test.png: Dir.Remove error: No such file or directory

So I am only able to read the crypt files when mounted via Google Drive File Stream, making the rclone crypt read-only in effect.

Also are there any plans down the line/on the road map to allow a more extensive mount with concurrent read/write access on a mount?


Hmm, you shouldn’t be getting that error. That means that somehow the data rclone thought it uploaded is not the same as what arrived on the google file stream.

It is probably caching problems…

It should be in the next release - just putting the finishing touches to it now!

Get link stream for google drive at: