Uploads to Drive files I don't own

What is the problem you are having with rclone?

I have folders shared with me. I would like to download the folders, but not upload the folders. This way if I accidentally change a file it is only for my local copy. I don't have any problems with the Sync to my local machine. When I sync to Drive using --drive-auth-owner-only it still updates any files that I have changed.

In my test, the Travel folder is shared with me. It contains three files that are not owned by me. I download these files to my local machine. Then I edit one file and re-sync. On Drive I see the new edited file with the changes I made. My assumption is that by using --drive-auth-owner-only, my changes wouldn't make it back to drive. Is this the correct assumption?

thanks

What is your rclone version (output from rclone version)

rclone v1.53.3 (I don't see anything in the release documentation for 1.54 about this feature)

Which OS you are using and how many bits (eg Windows 7, 64 bit)

Linux Manjaro Release 20.2.1 64-bit

Which cloud storage system are you using? (eg Google Drive)

Google Drive

The command you were trying to run (eg rclone copy /tmp remote:tmp)

rclone sync /home/mff/Data/Work/CCC/Travel/ CCC:/Travel/ -Lu --drive-skip-gdocs -vv --exclude /PCC/** --log-file /home/mff/logs/SyncCCC.log --exclude-from /home/mff/bin/syncCCC_Excludes --drive-auth-owner-only

The rclone config contents with secrets removed.

[CCC]
type = drive
client_id = id
client_secret = secret
scope = drive
token = {"access_token":"token"}
root_folder_id = folder_id

A log from the command with the -vv flag

2021/02/08 14:15:11 DEBUG : rclone: Version "v1.53.3" starting with parameters ["rclone" "sync" "/home/mff/Data/Work/CCC/Travel/" "CCC:/Travel/" "-Lu" "--drive-skip-gdocs" "-vv" "--exclude" "/PCC/**" "--log-file" "/home/mff/logs/SyncCCC.log" "--exclude-from" "/home/mff/bin/syncCCC_Excludes" "--drive-auth-owner-only"]
2021/02/08 14:15:11 DEBUG : Creating backend with remote "/home/mff/Data/Work/CCC/Travel/"
2021/02/08 14:15:11 DEBUG : Using config file from "/home/mff/.config/rclone/rclone.conf"
2021/02/08 14:15:11 DEBUG : Creating backend with remote "CCC:/Travel/"
2021/02/08 14:15:11 DEBUG : fs cache: renaming cache item "CCC:/Travel/" to be canonical "CCC:Travel"
2021/02/08 14:15:11 DEBUG : Google drive root 'Travel': Waiting for checks to finish
2021/02/08 14:15:11 DEBUG : Google drive root 'Travel': Waiting for transfers to finish
2021/02/08 14:15:13 DEBUG : exam1.tex: MD5 = a29afb1a00bf168d4fe9842cc649c1bd OK
2021/02/08 14:15:13 INFO  : exam1.tex: Copied (new)
2021/02/08 14:15:13 DEBUG : user-overrides.js: MD5 = 99a6475f4c7af3f9b9ec1dd5c1b083cd OK
2021/02/08 14:15:13 INFO  : user-overrides.js: Copied (new)
2021/02/08 14:15:13 DEBUG : mychart.pdf: MD5 = 8c4dffe99446620fef98863e7f35533c OK
2021/02/08 14:15:13 INFO  : mychart.pdf: Copied (new)
2021/02/08 14:15:13 DEBUG : Waiting for deletions to finish
2021/02/08 14:15:13 INFO  : 
Transferred:   	  223.878k / 223.878 kBytes, 100%, 147.286 kBytes/s, ETA 0s
Transferred:            3 / 3, 100%
Elapsed time:         2.4s

2021/02/08 14:15:13 DEBUG : 8 go routines active

--drive-auth-owner-only is more about the files you can see on the drive when listing it, rather than what gets uploaded.

I think the best way to achieve this would be to use filters in the upload so you don't attempt to upload those directories.

Thanks that is what I was seeing and the conclusion I was coming to. I just wanted confirmation before I used that solution.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.