Uploading to acd without checking


as you all know uploading to ACD using “rclone move” may take quite some time because rclone waits until the file appears. Looking at my recent uploads I only had 1 file (out of ~900) which needed a second try. So in order to save time and speed up the upload process I tried to eliminate all checks regarding ACD. I used --acd-upload-wait-per-gb=0s and --retries=0 which resulted in rclone not doing anything. With retries 1 rclone uploaded the file just fine but of course does a second try because the first one “failed”. Is it intented that rclone does not upload when setting retries to 0 or is it something on my end which I am doing wrong?

Edit: After looking at the source I spotted that “retries” rather relates to “attempts” (you should propably rename that as it’s a bit misleading). However even when I use retries=1 it still uploads the file multiple times (which doesn’t make sense as it should exit the for-loop in cmd.Run. The value I’m assigning is parsed correctly so something is faulty in code (or I’m not understanding the retry system correctly).

Edit 2: Fixed after setting low-level-retries to 1.

So did it save time?

I’m operating on a server which does not have much disk space. So I have to run my upload script after 2 oder 3 bigger downloads. During the upload all ongoing downloads are paused in order to not fill up the drive. This costs quite some time because eventually I’m just waiting for minutes (or sometimes even an hour or more) for the files to show up on ACD.

Setting the values I mentioned does of course not speed up the upload itself, but it allows rclone to finish earlier and delete the files so I can get my downloads going again.