Union misbehaving with google drive and the all policy

What is the problem you are having with rclone?

Been trying to set up rclone to upload to multiple remotes, using the union remote to unite them.
I figured the all policies would do the trick, as multiple google searches lead me to believe.

This works great for my jotta and dropbox remote, once i introduce a gsuite (never tested a private) google drive, either teamdrive or not it halts.

The config works just fine if i do a move or touch on the remote itself

What is your rclone version (output from rclone version)

Tried multiple, same result
rclone v1.52.3-290-g82975109-beta
rclone v1.52.3
rclone v1.52.2

Which OS you are using and how many bits (eg Windows 7, 64 bit)

binary directly on Pop_OS20.04
and a assortments of docker containers, hotio/rclone:stable, hotio/rclone:unstable, rclone/rclone, rclone/rclone:beta

Which cloud storage system are you using? (eg Google Drive)

Jotta and Google Drive

The command you were trying to run (eg rclone copy /tmp remote:tmp)

rclone touch union:test

Also played with copy and move with actual files.

The rclone config contents with secrets removed.

type = jottacloud
tokenURL = https://id.jottacloud.com/auth/realms/jottacloud/protocol/openid-connect/token
token = **
configVersion = 1

type = union
upstreams = jotta:backups/BotBox RostBackup:/BotBox
create_policy = all
action_policy = all

type = drive
client_id = **
client_secret = **
scope = drive
token = **
team_drive = **

A log from the command with the -vv flag

# rclone touch -vv union:test
2020/08/24 11:58:36 DEBUG : rclone: Version "v1.52.3" starting with parameters ["rclone" "touch" "-vv" "union:test"]
2020/08/24 11:58:36 DEBUG : Using config file from "/config/rclone.conf"
2020/08/24 11:58:37 DEBUG : fs cache: renaming cache item "RostBackup:/BotBox" to be canonical "RostBackup:BotBox"
2020/08/24 11:58:37 DEBUG : fs cache: switching user supplied name "RostBackup:/BotBox" for canonical name "RostBackup:BotBox"

It sits here, left over night


Can you kill -QUIT the rclone process when it hangs and post the output.

Also of you try making a union with two local directories does it go wrong in the same way? That would rule out a bug in the backends.

I do actually see the same behavior on local unions, but it is creating the files.
Im attaching the trace where the union consist of a local directory, and a google drive remote.

Something odd is going on there for definite. The upload process appears to be wedged somehow

Can you make an issue on GitHub about this with a way to reproduce it and a link to this forum post and I'll take a look next week when I'm back at my desk. Hopefully with a few more tools it should be obvious what is going on.

Thank you

Done :slight_smile: https://github.com/rclone/rclone/issues/4534

1 Like

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.