Union is working properly with Storj backend

What is the problem you are having with rclone?

When using multiple Storj backend in Union.... once the first drive is full it is not automaticaly selecting the next one. Or MFS, LNO these Union policy is not considered.

Run the command 'rclone version' and share the full output of the command.

rclone v1.58.1

  • os/version: debian 11.3 (64 bit)
  • os/kernel: 5.15.32-v8+ (aarch64)
  • os/type: linux
  • os/arch: arm64
  • go/version: go1.17.9
  • go/linking: static
  • go/tags: none

Which cloud storage system are you using? (eg Google Drive)

Storj

The command you were trying to run (eg rclone copy /tmp remote:tmp)

Issue with Rclone union while using rclone move or Rclone copy

The rclone config contents with secrets removed.

[uTani]
type = union
upstreams = ******Tani:/ *****Tani:/
create_policy = lno

A log from the command with the -vv flag

Paste  log here

The storj backend doesn't support reading how many files / how much space is used, so any policy using that is unlikely to work very well.

is there any other way i can do it automatically......instead of manually changing the backend in union

Not at the moment... Maybe I should make an API for the union backend so you could do it there - would that help?

i think it should work....will it help in using the policy

does the api provides a way to check the space.....

The storj API doesn't provide a way to read the used space.

1 Like