Unable to serve by http or webdav


#1

Hi,

I’m unable to serve my gdrive by webdav or http:

root@Fileserver:/mnt/.local/cloud# rclone serve -vv http gdrive:/
2017/12/27 20:01:27 DEBUG : Using config file from “/root/.config/rclone/rclone.conf”
2017/12/27 20:01:27 DEBUG : rclone: Version “v1.39” starting with parameters [“rclone” “serve” “-vv” “http” “gdrive:/”]
2017/12/27 20:01:28 INFO : Google drive root ‘’: Modify window is 1ms
2017/12/27 20:01:28 DEBUG : vfs cache root is “/root/.cache/rclone/vfs/gdrive”
2017/12/27 20:01:28 NOTICE: Google drive root ‘’: Serving on http://localhost:8080/
2017/12/27 20:01:28 DEBUG : Google drive root ‘’: Checking for changes on remote
2017/12/27 20:01:28 DEBUG : Google drive root ‘’: All changes were processed. Waiting for more.

I now try to access via chrome with url: http://ipofrclone:8080

But I just get this:

Diese Website ist nicht erreichbar
10.0.3.10 hat die Verbindung abgelehnt.
Auf Google nach 8080 suchen
ERR_CONNECTION_REFUSED

Did I something wrong?


#2

Hello ErAzOr,

By default, when rclone serve http is used, it is bound to localhost:8080 ( localhost:8081 for webdav ), meaning that it it can only be accessed from the computer it is currently running on. This was likely chosen, because there is no encryption or authentication built into it.

Basically you have 2 options:
Allow Remote, with encryption + authentication. Run a proxy on top of the rclone serve, on the computer running rclone. Caddy ( caddyserver.com ) is perfect for this. This allows adding authentication and https to the server, as well as being able to access it from other computers. I made a basic overview of how to do this here: Windows share of a mount

OR ( If you’re on a very secure network, and don’t mind making your share accessible to everyone on the Network ) - add the option --addr ipofrclone:8080 to the rclone serve command ( replacing as needed ). Something like:
rclone serve http --vv --addr ipofrclone:8080 gdrive:

Good luck,
jedi453


#3

That did the trick. Thank you!


#4

That is correct…

I liked your write up of how to add caddy in front of rclone serve - fancy adding a page to the rclone wiki with that in?

Note that you can just write

 rclone serve http --vv --addr :8080 gdrive:

Which will serve on all IP addresses


#5

FYI: I’ve Created the requested wiki page here.

If anyone sees any problems/flaws, please edit it or let me know!

Thanks,
jedi453


#6

Nice one - thank you :slight_smile: