Unable to perform server side copy

What is the problem you are having with rclone?

Have authenticated GDrive remote. Trying to do server side copy between Shared Folder (via link) and my GDrive. Keep running into 403 Forbidden errors.

What is your rclone version (output from rclone version)

1.13.7

Which OS you are using and how many bits (eg Windows 7, 64 bit)

Win10, 64

Which cloud storage system are you using? (eg Google Drive)

GDrive

The command you were trying to run (eg rclone copy /tmp remote:tmp)

rclone --drive-root-folder-id=0B-E2Dp0ohgNPYWZhYzkyODktN2Y3OS00MDA5LWJkMzctZjY4OGJlZDIxMDUx lsf gdrive_root:

Perfectly returns the contents of the shared folder, per the GDrive Web GUI.

rclone --drive-root-folder-id=0B-E2Dp0ohgNPYWZhYzkyODktN2Y3OS00MDA5LWJkMzctZjY4OGJlZDIxMDUx copy gdrive_root: gdrive_root:/folderA/

returns with 403 Forbidden error with -vv or log-level DEBUG

The rclone config contents with secrets removed.

[gdrive_root]
type=drive
scope=drive
token={"access token"...

A log from the command with the -vv flag

DEBUG : Using config file from "rclone.conf"
2020/06/30 10:46:53 DEBUG : 576_GD: Loaded invalid token from config file - ignoring
2020/06/30 10:46:54 DEBUG : Keeping previous permissions for config file: -rw-rw-rw-
2020/06/30 10:46:54 DEBUG : 576_GD: Saved new token in config file
2020/06/30 10:46:55 DEBUG : 576_GD: Loaded fresh token from config file
2020/06/30 10:47:01 ERROR : ITC, T/S01/0101: Failed to copy: failed to make directory: googleapi: Error 403: Forbidden, forbidden
2020/06/30 10:47:02 INFO  : Google drive root 'folderA': Waiting for checks to finish
2020/06/30 10:47:02 INFO  : Google drive root 'folderA': Waiting for transfers to finish
2020/06/30 10:47:04 ERROR : ITCS1/0102: Failed to copy: failed to make directory: googleapi: Error 403: Forbidden, forbidden

Also, can attest that the remote itself, works with other commands like sync, moveto in between local PC and GDrive. Are client_id and client_sauce required are an operation like this?

Oops, rclone v1.51, go 1.13.7

It doesn't seem you are authenticated and that root id looks a bit odd.

What's the reason you are setting the root id?

You should be able to do just rclone ls gdrive_root:

doesn't seem that you're authenticated.

Using same gdrive_root remote, I have uploaded and downloaded ~60Gb data from PC to root of GDrive

What is the reason you're setting root-id?

Setting root id for the source argument of copy command.
So, rclone copy {source=public shared gdrive|--drive-root-folder-id gdrive_root:} {dest: my personal gdrive space in folderA|gdrive_root:folderA}

It'd be rather helpful if you told me what command you'd use to copy files from https://drive.google.com/drive/u/0/folders/1FhYNBYx8XyCFpNUpr4Yj29WniLel34jG over to your personal drive remote?

rclone copy --drive-root-folder-i=1FhYNBYx8XyCFpNUpr4Yj29WniLel34jG remote: remote:/Shared

Is that right?

The problem is that the --drive-root-folder-id is applying to both the gdrive_root: remotes which I think is not what you want.

Make a copy of the gdrive_root remote called drive_root2 say and in that copy add drive_root_folder_id = 0B-E2Dp0oh...

Then you should be able to do

rclone copy gdrive_root2: gdrive_root:/folderA/

Baby steps. We figure out how to list each and move forward. It's not easy to jump to a solution without understanding what the problem is.

Nick shared the commands already.

Hi Nick, really appreciate what you're doing for the community.

I had suspected the same, and did what you asked.
And it works, thanks a lot :slight_smile:

I used root_folder_id instead of drive_root_folder_id, unsure if they're different.

However, the -P output shows speeds of only 70kbps for server side copy, so it's routing public shared folder -> rclone.exe -> my_gdrive, instead of public shared folder -> my_gdrive. Any flag to fix this?

Can you share the -vv as it'll show if it's doing a server side copy or not?

However, the -P output shows speeds of only 70kbps for server side copy, so it's routing public shared folder -> rclone.exe -> my_gdrive, instead of public shared folder -> my_gdrive. Any flag to fix this?

Fixed by adding '--drive-server-side-across-configs' flag. Thank y'all so much.

1 Like

That's the one!

You are welcome! Maybe you would consider supporting the project? Thanks!