Unable to mount Google Unlimited Storage shared drive because of an I/O error, can't list buckets without project number


####What is the problem you are having with rclone?

I would like to mount my Google Unlimited Storage shared drive.
The virtual drive does show up but return : "The request could not be performed because of an I/O error" when I try to open it

The console returns this error four times in a row:
ERROR : /: Dir.Stat error: can't list buckets without project number
ERROR : IO error: can't list buckets without project number

I did try to gather infos on the project number and buckets in the console.developers.google.com without luck.
Other threads have a similar problem with a different kind of error.

Mounting the "gdrive" works fine but it isn't what I need and the "google cloud storage" doesn't.

I tried with multiple accounts, always getting the same result.

####What is your rclone version (output from rclone version)

rclone v1.53.3
go version: go1.15.5

####Which OS you are using and how many bits (eg Windows 7, 64 bit)

os/arch: windows/amd64

####Which cloud storage system are you using?

Google Shared/Team Drive

####The command you were trying to run

rclone mount gdrive_unlimited:/ G:

####Rclone config

type = google cloud storage
token = {"access_token":"insert token here","token_type":"Bearer","refresh_token":"","expiry":""}

More -vv logs at: https://pastebin.com/ZgLZSb0a

Any help or indication would be truly appreciated.

Kind regards

I think you've configured "Google Cloud Storage" not "Google Drive". Try remaking the config and choose the type of the remote as "drive" and hopefully it will work.

I did try with Google Drive but unfortunately, it shows the 15GB drive and not the Unlimited one.
I am able to mount the Google Drive without issue, but I am looking to mount the shared one.

Thank you for your suggestion anyway.

If it's shared with you, you need to use the shared with me:

It works!

Your answer was not perfect, but it sure guided me towards the solution.
The names of the various drives are very confusing: Google Drive = Team Drive = Google Unlimited Storage ≠ Google Cloud storage
The trick was to set it up as a Team drive, even though I own it and it being shown as "shared with me".

Thank you so much for your help

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.