Unable to find copied file on Google Drive

I have just set up rclone on CentOS 7. Everything seems to have been setup correctly, thanks for the awesome documentation.

# rclone config file
Configuration file is stored at:
/root/.config/rclone/rclone.conf

# cat /root/.config/rclone/rclone.conf
[gdrive-linode]
type = drive
client_id = 595217786392-exxxx5ckjb.apps.googleusercontent.com
client_secret = luTGxxxxxxxxxxSj-wHNb7Ce7e
scope = drive
service_account_file = /Backups/scripts/gdrive-linode-backups-d310xxxxxxx38.json
root_folder_id = 0AK5ekeukadadsadPVA

# rclone listremotes
gdrive-linode:

I copied a file using the following command.

# rclone copy /Backups/scripts/a.php gdrive-linode:

Then I check the file copied via this command:

# rclone ls gdrive-linode:
      597 a.php

But when I login to my Google Drive via a web browser, I'm unable to locate a.php anywhere.

I've done logout-login, refresh etc.

What am I missing?

Thanks!!

I tried the following command:

rclone -v --drive-impersonate service-account-email-xxx gserviceaccount..com copy /tmp/BACKUP-MYSQL-Sun/AGS.sql.gz gdrive-linode:Linode-OST

No errors, files copied but still I'm unable to see the uploaded files via the web.

What should be the "user" part in "--drive-impersonate user"?

Is there anything else I'm doing wrong?

Thanks

Why are you using a service account?

If you aren't seeing something, I'd think your service account is pointing to something else.

The drive-impersonate-user is whatever user you want the service account to impersonate assuming that's where you set it up.

Are you using a GSuite account?

Honestly speaking, Google configuration was overwhelming for me. I tried to follow the steps in one of the guides here, but what I was doing was more or less cloudy for me.

Are you using a GSuite account?

No, a regular account. Once everything works well, I plan to buy 100GB storage.

Any ideas on how I should go about fixing things?

Thanks a ton!!

I'm not sure how you made a service account as that's used with GSuite accounts.

I would just delete the remote, make a new one and use regular Gmail account when you authenticate.

Okay, will do that now... will share feedback or questions in the next 10 min.

Since I'm on a CentOS terminal, any ideas how should I deal with this step?

If your browser doesn't open automatically go to the following link: http://127.0.0.1:53682/auth?state=ayxWygSHwV-xxxxxxxxx-B64A
Log in and authorize rclone for access
Waiting for code...

Pick headless:

And it'll give you a link to paste into a browser and you paste the code back in.

Absolutely, how stupid of me....
Got it working!!
Thanks a ton @Animosity022

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.