Unable to Delete Backed up Files on rclone Mount/SFTP

What is the problem you are having with rclone?

I can't use regular rm command on a rclone mount, because there are files starting with a question mark as you'll notice below. For unknow reasons to me, there are some files starting with a question mark. All of them cannot be deleted. Those files are the result of the following options: --backup-dir—I kept those files for a while, then delete them manually.

However, those files can be deleted via rclone GUI, but the rclone GUI does not offer a mean to bulk delete all these problematic files. Indeed, I've got hundreds of them I'd like to delete.

What is your rclone version (output from rclone version)

$ rclone version
rclone v1.55.1

  • os/type: darwin
  • os/arch: amd64
  • go/version: go1.16.3
  • go/linking: dynamic
  • go/tags: cmount

Which OS you are using and how many bits (eg Windows 7, 64 bit)

MacOS Mojave 10.14.6

Which cloud storage system are you using? (eg Google Drive)

SFTP with:

type = crypt

The command you were trying to run (eg rclone copy /tmp remote:tmp)

This is the commad I use to backup:

rclone -v  --log-file=/tmp/rclone.log --filter-from /usr/local/etc/rclone/filter_mbp.txt sync ~ Safe:/MBP/ --backup-dir Safe:/OLD/MBP/$date

Later, I'll issue:

$ rclone mount --daemon Safe: /usr/local/mnt/rclone > /dev/null 2>&1

$ llh
gls: cannot access 'Capture d’écran 2020-08-07 à 15.01.17.png': No such file or directory
total 0
-????????? ? ? ? ?                ? 'Capture d’écran 2020-08-07 à 15.01.17.png'

$ rm Capture\ d’écran\ 2020-08-07\ à\ 15.01.17.png
grm: cannot remove 'Capture d’écran 2020-08-07 à 15.01.17.png': No such file or directory

The reason I like to use regular rm command is because I can see what am I deleting…

The rclone config contents with secrets removed.

type = crypt
remote = [VPS]:/home/[USER]/RESCUE
filename_encryption = standard
password = 
password2 = 
directory_name_encryption = true

type = sftp
host = [IP ADDRESS]
user = [USER]
port = [PORT]
key_use_agent = true
md5sum_command = md5sum
sha1sum_command = sha1sum

A log from the command with the -vv flag

The issue is I can't use the rm command, because rclone seems to prefix files with a question mark when moved using --backup-dir Safe:/OLD/MBP/$date option.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.