Unable to connect to rsync.net ssh: handshake failed: ssh: unsupported DSA key size 2048

Thanks so much for your help @ncw and @saschatrebbin

Thanks again for patching to support 2048 length DSA keys.

Just a followup to document another solution:

Support at rsync.net suggested forcing the use of ssh-ed25519 by using the HostKeyAlgorithms option.

You can add the following line to your ssh config (~/.ssh/config):

HostKeyAlgorithms ssh-ed25519

You can add the following line to your rclone config (~/.config/rclone/rclone.conf)

path_override = ssh -oHostKeyAlgorithms=ssh-ed25519

Or you can pass an option via the command line using --sftp-path-override

--sftp-path-override "ssh -oHostKeyAlgorithms=ssh-ed25519"

That won't work with rclone as it doesn't use the system ssh alas

This is what the path_override config var is for... It won't let you use the system ssh (though that isn't a bad idea for a different flag).


Override path used by SSH connection.

This allows checksum calculation when SFTP and SSH paths are
different. This issue affects among others Synology NAS boxes.

Shared folders can be found in directories representing volumes

rclone sync /home/local/directory remote:/directory --ssh-path-override /volume2/directory

Home directory can be found in a shared folder called "home"

rclone sync /home/local/directory remote:/home/directory --ssh-path-override /volume1/homes/USER/directory
  • Config: path_override
  • Type: string
  • Default: ""
1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.