Unable to auto mount google drive on Windows

I just discovered rclone today and I have tried my best to do my research even though I am a bit below average about these stuff.

I have been able to connect my google drive to my computer using rclone and everything works perfectly.
My issue is I cannot make auto mount to work when my computer restarts.

Location of my config file

Location of rclone

I followed a youtube video and for me to access my google drive, on the command prompt, I run
rclone mount TeamBio: drive and then inside rclone folder, I see a folder named drive and it has all my folders on my google drive account. Closing the command prompt, also disconnects me from google drive.

Inside rclone folder, I have also saved nssm.exe

Things I have tried

  1. Followed instructions on this board about setting this as a system service using nssm but every time I try to manually run from services.msc, there is an error and it pauses it. Restarting the system results to the same outcome.

  2. I have also tried to do task scheduler but I have not been able to succeed from what I have read from people. I am a bit confused with the parameters section. I also read about creating a batch file? Can you guide me on what to fill with the task scheduler app with the information I have given above?

I would really appreciate any help. Thank you in advance.

hello and welcome to the forum,

here is simple batch file, let's call it mountx.cmd

C:\data\rclone\scripts\rclone.exe mount secret2: x: --log-file=log.mount.txt --log-level=DEBUG

here is the task scheduler


Thank you so much for your reply asdffdsa

I will give it a go and let you know!

Bud, what is that in your Start in part of task scheduler?

I just put whatever was on the batch file and I got an error
The error code “0x8007010B” in this case means that the “Start In” folder is incorrect (or entered incorrectly)

that is the folder the batch file is in

1 Like

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.