Unable to access remote folder in file browser unless root

Happy weekend,

To keep it simple:

Title says it all: In my chosen file manager, I am unable to access the folder I set up in RC unless I open the file manager as root.


I have been trying to set up a systemd service called rclonemount.service with the below contents:

[Unit]
Description=RClone Mount On-Login
After=network.service
After=network-online.target

[Service]
Type=simple
RemainAfterExit=true
ExecStartPre=mkdir -p /home/aj/PutIO

ExecStart=rclone mount putio: /home/aj/PutIO --config /home/aj/.config/rclone/rclone.conf --checkers 16 --dir-cache-time 60m --quiet --read-only --daemon                           

ExecStop=/bin/fusermount -u /home/aj/PutIO

Restart=always
RestartSec=10

[Install]
WantedBy=default.target

What about the above contents of my rclonemount.service file is causing this to be mounted so that only root can access it?

  • If attempting to access without being root, I get an error dialogue pop-up in my file manager which says: Could not display "/home/aj/PutIO". The location is not a folder.

  • The individual commands entered into Terminal by themselves will mount the PutIO folder in the correct location in my home folder and enable me to access the directories within remote: while browsing file manager without elevated privilege.

  • In terminal and without sudo, I can enter rclone lsd putio: to successfully show directories of remote: root location; this is after the attempt to utilize the systemd service.

*I have enabled and disabled and restarted the daemon multiple times with systemctl disable rclonemount.service --now, systemctl enable rclonemount.service --now, and systemctl daemon-reload.

Thanks for any time or consideration the community can give to this matter.

hello and welcome to the forum,

have you tried adding --allow-other?

Thanks for replying, I haven't tried --alow-other.

Follow-up question regarding access to others:
For the purposes of filesharing to other users via separate application over a network; does option: allow-other also allow access for these users which are external to this system/machine?

It seems self-explanatory, but I want to know if I'm allowing anyone access to anything I don't want to.

Similar to my OP, previously to this and while still using CLI to mount/unmount my drive on every log-in... I was unable to access the remote folder while browsing through file manager as root.

Is this something that runs along the same train tracks?

Can you please elaborate or PM me about what you mean? The VPN bit is the rabbit hole that got me to this point in the first place as my RC mounted folder is inaccessible when using VPN.

The folder "PutIO" which represents the remote: I have mounted with rclone(RC)

Apologies, I am not familiar with linux to the extent which most users are here.
Simply put: my rclone mount is not accessible when behind VPN. I don't know why this happens, but I assume it has something to do with IP addresses and/or ports being changed when firing up the VPN. I didn't know what you meant by trying rclone serve sftp/ft/webdav/dlna. I could assume that you meant add it as another line to my systemd service, but then I would need to ask how you suggest appending that to my current systemd .service file.

"RC mounted folder" is just the short, abbreviated way I chose to type out 'rclone' for identification only by users on this thread/forum. Instead of typing "rclone" when I asked for help, I typed 'RC' like the lazy POS I am.

rclone is working, I stated that in my OP before subject of VPN was raised.

This is getting away from topic...

Re-typed without using RC:

  • Title says it all: In my chosen file manager, I am unable to access the folder I set up in rclone unless I open the file manager as root.

rclone is working because as I wrote in my OP:

See above quote again.

I know - a layer of complexity which allows me to create a boot-persistent startup process to mount the PutIO mountpoint using rclone without requiring me to use CLI each and every time I want to reboot or log off.

I mean... even if the reason I use VPN for my rclone purposes is frowned-upon here or elsewhere, I would still have a preference to not be required to disconnect a VPN for the sole purpose of wanting to connect to my rclone mountpoint via my file manager just so I can copy, move, remove, or execute files.

I want to be able to get into that folder mountpoint while I am still connected to my VPN. I was just asking how it was possible since you mentioned it - unless that functionality is not possible in rclone.

All that aside and before derailment, the main point of this topic was so that I could get assistance figuring out a way to get the systemd file working which I mentioned in OP.

Please also explain why would allow-other cause the systemd file to suddenly work -IF- allow-other was not needed when copying/pasting the same commands into terminal from the systemd file?

In other words:

When using Terminal to enter the commands which are located in my systemd file, allow-other is not needed.

When entered separately, each of the commands located inside the systemd file will successfully mount my PutIO mountpoint in my /home/user/ location AND allow me to view them in the file manager of my choice without needing to be root.