Unable to access remote after copying config to different machine

What is the problem you are having with rclone?

I have rclone running well locallly in my machine. I just got my hand on a server and thought to try rclone there so i simply copied my rclone.conf to the appropriate directory using sftp
( I did rclone config file to know the correct directory in server )

After i pasted the config , i ran rclone size test:
( Test being my remote name )
I am getting the following error

2020/05/27 06:13:20 DEBUG : rclone: Version "v1.51.0-371-gc08617c7-beta" starting with parameters ["rclone" "size" "test:" "-vv"]  
2020/05/27 06:13:20 DEBUG : Using config file from "/root/.config/rclone/rclone.conf"     
2020/05/27 06:13:22 DEBUG : 6 go routines active    

2020/05/27 06:13:22 Failed to size: list: failed to resolve shortcut: googleapi: Error 404: File not found: 1vhdDoCXVNYXEV2nAmyGKx1cq0LTxxf95., notFound  

This same remote/config is working well in my local machine where i copied the config from , it doesn't give any such error

What is your rclone version (output from rclone version)

rclone v1.51.0-371-gc08617c7-beta -

Which OS you are using and how many bits (eg Windows 7, 64 bit)

os/arch: linux/amd64
go version: go1.14.3

Which cloud storage system are you using? (eg Google Drive)

Google Drive

What rclone version did you have on your source machine? The error is complaining about a Google drive shortcut that isn't working. One of the features of the beta adds shortcuts. You should search for that shortcut and probably remove it since it points to a file that is missing.

Here is the rclone version in my source machine

$ rclone version
rclone v1.51.0
- os/arch: android/arm64
- go version: go1.13.7

Output of rclone size test: in source machine

$ rclone size test: -vv
2020/05/27 14:49:19 DEBUG : rclone: Version "v1.51.0" starting with parameters ["rclone" "size" "test:" "-vv"]
2020/05/27 14:49:19 DEBUG : Using config file from "/data/data/com.termux/files/home/.config/rclone/rclone.conf"
2020/05/27 14:49:21 DEBUG : [LittleSubs] Love Letter 1995 (BD 1920x1080 x264 AAC 5.1ch).mp4: Ignoring unknown document type "application/vnd.google-apps.shortcut"
2020/05/27 14:49:21 DEBUG : Tenki no Ko Weathering with You_WEB-DL 1080p.mkv: Ignoring unknown document type "application/vnd.google-apps.shortcut"
2020/05/27 14:49:21 DEBUG : MIDE-742.iso: Ignoring unknown document type "application/vnd.google-apps.shortcut"
2020/05/27 14:49:21 DEBUG : Date With an Angel 1987 720p WEB-DL AAC2.0 H.264-alfaHD天使在人间.mkv: Ignoring unknown document type "application/vnd.google-apps.shortcut"
2020/05/27 14:49:21 DEBUG : 创建edu邮箱.docx: Ignoring unknown document type "application/vnd.google-apps.shortcut"
Total objects: 402
Total size: 228.336 GBytes (245173491418 Bytes)
2020/05/27 14:49:31 DEBUG : 19 go routines active
2020/05/27 14:49:31 DEBUG : rclone: Version "v1.51.0" finishing with parameters ["rclone" "size" "test:" "-vv"]

Shouldn't the server where i pasted the rclone config report this same thing
Only difference i can tell is the rclone used in server is latest beta while in source machine it is the stable release v1.51.0

The new version is detecting shortcuts. The old version isn't. You can turn that off or fix the shortcuts. In the old version it doesn't understand what that type is so its erroring.


1 Like

Thanks that fixed it.. i also did rclone size on a gdrive folder without any shortcuts in source and destination machine using same rclone config and all good

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.