Trying to shrink cache size

What is the problem you are having with rclone?

Rclone cache size seems to be getting out of control and looking to shrink it.

It's taken up over 475gb of my 1tb server space.

What is your rclone version


Which OS you are using and how many bits (eg Windows 7, 64 bit)

Ubuntu 18.04 64bit minimal

Which cloud storage system are you using? (eg Google Drive)


The command you were trying to run (eg rclone copy /tmp remote:tmp)

Command I mounted with was mount mega: /home/hhh/mega --vds-cache-mode full --allow-others

The rclone config contents with secrets removed.

Paste config here

A log from the command with the -vv flag

Paste  log here

You need to set:

--vfs-cache-max-size SizeSuffix      Max total size of objects in the cache. (default off)

what size would be recommended as it says max total size ?

and size suffix would i change to the amount?

That's really up to you. You can set it to whatever size makes sense for your environment.

Whatever you'd like. I use:

 --vfs-cache-max-size 750G

Because I have a 1TB drive and have some spare room on it.

1 Like

thank you. i will try that now

just to confirm the full command would be

rclone mount mega: /home/hhh/mount --vfs-cache-mode full --vfs-cache-max-size 600G --allow-other

to set a 600gb cache max size

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.