Transfer to iDrive does not start

What is the problem you are having with rclone?

I am trying to transfer one file to iDrive. The transfer does not start. I use the -P switch on 'rclone copy' and I see the status text, but it all stays on 0 bytes transferred. Log with -vv is below.

Run the command 'rclone version' and share the full output of the command.

clone v1.65.1
- os/version: ubuntu 22.04 (64 bit)
- os/kernel: 5.15.0-91-generic (x86_64)
- os/type: linux
- os/arch: amd64
- go/version: go1.21.5
- go/linking: static
- go/tags: none

Which cloud storage system are you using? (eg Google Drive)

iDrive

The command you were trying to run (eg rclone copy /tmp remote:tmp)

rclone copy media/MediaF/Movies/subdir/subdir/movie.mkv idrive:stuff -vv

Please run 'rclone config redacted' and share the full output. If you get command not found, please make sure to update rclone.

[idrive]
type = s3
provider = IDrive
access_key_id = XXX
secret_access_key = XXX
region = eu-central-1
acl = private
endpoint = e2f3.fra3.idrivee2-58.com

The 'region' line wasn't there after I had set up the iDrive remote with 'rclone config'. I added it myself later to see if it would make any difference (it does not).

A log from the command that you were trying to run with the -vv flag

2024/02/13 00:33:38 DEBUG : rclone: Version "v1.65.1" starting with parameters ["rclone" "copy" "media/MediaF/Movies/subdir/movie.mkv" "idrive:stuff" "-vv"]
2024/02/13 00:33:38 DEBUG : Creating backend with remote "media/MediaF/subdir/movie.mkv"
2024/02/13 00:33:38 DEBUG : Using config file from "/home/dinosm/.config/rclone/rclone.conf"
2024/02/13 00:33:38 DEBUG : fs cache: adding new entry for parent of "media/MediaF/Movies/subdir/movie.mkv", "/home/dinosm/media/MediaF/Movies/subdir"
2024/02/13 00:33:38 DEBUG : Creating backend with remote "idrive:stuff"
2024/02/13 00:33:38 DEBUG : Resolving service "s3" region "eu-central-1"
2024/02/13 00:33:38 DEBUG : movie.mkv: Need to transfer - File not found at Destination
2024/02/13 00:33:38 DEBUG : movie.mkv: multi-thread copy: disabling buffering because source is local disk

And that's where it gets stuck. Nothing else happens after that.

hi,
with s3 remotes, upload is a two-step process

  1. calculate the md5 hash, which takes time to complete.
  2. upload the file.

so that might be the issue.
can test --s3-disable-checksum

fwiw, all my idrive remotes do not use region

That did it! Thank you!

I am guessing the checksum on a 70GB file takes a while to be computed :sweat_smile:

welcome.

fwiw, about --s3-disable-checksum, i would not use it.
that was just a suggestion for testing.

Too risky to possibly get corrupt files across?

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.