Token and mount fails after couple of minutes of working perfectly

What is the problem you are having with rclone?

After successfully mounting and configuring an rclone remote to my seedbox, the mount works perfectly until after about 30 minutes, it can no longer playback any file. A log file shows that the token could not be fetched

Run the command 'rclone version' and share the full output of the command.

rclone v1.61.1-DEV

  • os/version: gentoo 2.13 (64 bit)
  • os/kernel: 5.15.94-gentoo-whatbox (x86_64)
  • os/type: linux
  • os/arch: amd64
  • go/version: go1.19.4
  • go/linking: dynamic
  • go/tags: none

Which cloud storage system are you using? (eg Google Drive)

Google Drive

The command you were trying to run (eg rclone copy /tmp remote:tmp)

---screen -dm rclone mount --buffer-size=32M --dir-cache-time=84h --vfs-cache-mode=minimal --vfs-cache-max-age=6h --log-file=mylogfile.txt---

A log from the command with the -vv flag

---023/03/21 17:04:36 ERROR : IO error: open file failed: Get "": couldn't fetch token - maybe it has expired? - refresh with "rclone config reconnect gdrive:": oauth2: cannot fetch token: 401 Unauthorized
Response: {
"error": "unauthorized_client",
"error_description": "Unauthorized"---

--- did you rclone config reconnect gdrive:, did that not solve the problem?
--- that is much discussed in the forum......
--- not sure it will matter, use latest official rclone, not a custom compiled version.
rclone is a portable app, does not need to be installed.

Hello, I did use --- config reconnect gdrive: --- but the mount fails anyway with the same error in the log file after about 30-45 minutes.

I've been trying to read more topic in the forum to try and find a solution but I have not found a concrete solution yet

did not post the redacted config file so i need to ask

did you create your own client id/secret or using the default?

I'm using my own. I've tried using the default as well but I've always used my own

ok, i think we have enough basic info now for someone more experienced with gdrive to comment.

1 Like

---screen -dm rclone mount --buffer-size=32M --dir-cache-time=84h --vfs-cache-mode=minimal --vfs-cache-max-age=6h --log-file=mylogfile.txt---
that is not a valid command, can you post the exact command?
or better yet, add -vv and post the top thirty lines.

screen -dm rclone mount --buffer-size=32M --dir-cache-time=84h --vfs-cache-mode=minimal --vfs-cache-max-age=6h --log-file=mylogfile.txt gdrive: /home/slighz/Stuff/Mount

that's my command. the same command i've been using for a long time but I'm not sure what changed

imho, should only take a few minutes to create a new client id/secret and use that. often solves strange issues.

oh ok, new info.....
recently, google pushed a major change, rclone had to redo it's code to authorize rclone.
did whatbox recently update the version of rclone?

Disable OAuth OOB flow (copy a token) due to Google deprecation

I've actually been using a new client Id and secret from a new project I made 2 days ago. I had the same line of thought about my old ids having problems. But that has not solved any issue. The problem persists no matter what ids I use.

oh ok, new info.....

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.