Timezone Issue when copying to Google Photos

What is the problem you are having with rclone?

When using Rclone to upload a video to Google Photos, the timezone setting is not reflected correctly. I can set the correct shooting time by going directly to the Google Photos webpage, selecting all the photos, hitting the Change Time button, and selecting and confirming the time zone as my own.

Run the command 'rclone version' and share the full output of the command.

rclone v1.61.1

  • os/version: Microsoft Windows 11 Pro 22H2 (64 bit)
  • os/kernel: 10.0.22621.1413 (x86_64)
  • os/type: windows
  • os/arch: amd64
  • go/version: go1.19.4
  • go/linking: static
  • go/tags: cmount

Which cloud storage system are you using? (eg Google Drive)

Google Photos.

The command you were trying to run (eg rclone copy /tmp remote:tmp)

rclone copy "N:\Sony videos\2023-03-25" "llitphoto:upload" --transfers 40 -P -vv --log-file=rclonelog.txt

The rclone config contents with secrets removed.

Name                 Type
====                 ====
llitphoto            google photos
synolit              smb

e) Edit existing remote
n) New remote
d) Delete remote
r) Rename remote
c) Copy remote
s) Set configuration password
q) Quit config
e/n/d/r/c/s/q> q

A log from the command with the -vv flag

[rclonelog.txt|attachment](upload://hoHYhbAeFGg0DAMnLZpBCSaQ7jL.txt) (1.1 MB)

The modified times are clunky as the API doesn't really do well:

Google Photos (rclone.org)

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.