[Tardigrade] metainfo error: node ID is required in node URL

What is the problem you are having with rclone?

I'm unable to finish the Tardigrade rclone tutorial.
I'm stuck at rclone mkdir tardigrade:mybucket.

What is your rclone version (output from rclone version)

rclone v1.54.0
- os/arch: linux/amd64
- go version: go1.15.7

Which OS you are using and how many bits (eg Windows 7, 64 bit)

Kernel: 5.4.97-1-MANJARO x86_64 
bits: 64 
Desktop: Xfce 4.16.0 
Distro: Manjaro Linux

Which cloud storage system are you using? (eg Google Drive)


The command you were trying to run (eg rclone copy /tmp remote:tmp)

$ rclone mkdir tardigrade:mybucket

The rclone config contents with secrets removed.

type = tardigrade
satellite_address = europe-west-1.tardigrade.io
api_key = ...
passphrase = ...
provider = existing

A log from the command with the -vv flag

[folaht@pjehrsohmehj Tardigrada]$ rclone mkdir tardigrade:mybucket -vv
2021/03/04 16:43:32 DEBUG : rclone: Version "v1.54.0" starting with parameters ["rclone" "mkdir" "tardigradej:mybucket" "-vv"]
2021/03/04 16:43:32 DEBUG : Creating backend with remote "tardigrade:mybucket"
Enter configuration password:
2021/03/04 16:44:06 DEBUG : Using config file from "/home/folaht/.config/rclone/rclone.conf"
2021/03/04 16:44:06 Failed to create file system for "tardigrade:mybucket": tardigrade: access: uplink: metainfo error: node ID is required in node URL "europe-west-1.tardigrade.io"

hello and welcome to the forum,

why do think this is a bug?

are you using a Custom satellite address or 3rd-party satellite

based on that error, you need to use a node ID with the URL.

1 Like

So europe-west-1.tardigrade.io isn't considered to be a 1st-party satellite?

If so, then it's confusing, For Custom satellite address would thus mean at all times and so the option menu is never used.

really, do not know, just sharing that link on how to setup rclone.

Ah, well thank you for the help.
This resolved my issue.

In combination with two more of these issues, it became very difficult for me to set this up.

yeah, the first time can only be confusing once, never twice...

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.