Syntax question - I'm baffled

So this command works:

rclone copy -v --ignore-existing /Volumes/'1 TB Media #1'/Screenshots remote:/'T5 Drive 2'/'6. Music Master'/'iTunes Media'/screenshots

But this one does not:

rclone copy -v --ignore-existing /Volumes/'1 TB Media #1’/iTunes/‘iTunes Media’/Music remote:/'T5 Drive 2'/'6. Music Master'/'iTunes Media’/Music

Sweetness:scripts jason$ rclone copy -v --ignore-existing /Volumes/'1 TB Media #1’/iTunes/‘iTunes Media’/Music remote:/'T5 Drive 2'/'6. Music Master'/'iTunes Media’/Music
rclone copy source:path dest:path [flags]

--create-empty-src-dirs Create empty source dirs on destination after copy
-h, --help help for copy

Use "rclone [command] --help" for more information about a command.
Use "rclone help flags" for to see the global flags.
Use "rclone help backends" for a list of supported services.
Command copy needs 2 arguments maximum: you provided 6 non flag arguments: ["/Volumes/1 TB Media #1’/iTunes/‘iTunes Media’/Music remote:/T5" "Drive" "2/6." "Music" "Master/iTunes" "Media’/Music"]
Sweetness:scripts jason$

I've checked, rechecked, and rechecked some more ad nauseam the spelling and the directory structure. I tested with the screenshots folder and had no trouble placing it in the itunes media folder and the music folder. I've battled it out for a while now and thought it was time for some help / fresh pair of eyes.


Try to put your paths around double quotes and see if that works.

Tried it without success. What I ended up doing is changing the names of some folders on GDrive - using underscore rather than spaces or periods - and moving the actual files closer in on the tree. So far a "rclone check" has worked. Going to back up later and see how it goes.

There are special characters that might not be happy. Without seeing the actual command with a -vv, it would hard to tell though.

Alright - I've got it figured out down to the following:

When I type the command line fresh it works. No problems.

But when I try and run it in a script or try to copy or paste it it gives me the syntax error.

I have tried using textedit and "Atom" (another editor) and it doesn't make a difference.


You have special characters that aren't working. Try putting the paths in quotes:

rclone copy -v --ignore-existing "/Volumes/1 TB Media #1/iTunes/iTunes Media/Music" "remote:/T5 Drive 2/6. Music Master/iTunes Media/Music"
2019/06/26 15:47:56 Failed to create file system for "remote:/T5 Drive 2/6. Music Master/iTunes Media/Music": didn't find section in config file

Finally! It was %^*#^% smart quotes.

Thanks so much for the help. I can't believe I wasted HOURS. Lol.

Even though I was using plain text editors and even Atom it was still turning them into smart quotes (too small for my eyes to pick up!)


Ha! I turned off smart quotes in the forum for the same reason!

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.