Syntax error rclone plex

Note that rclone translated it into a unicode lookalike for Windows! See encoding docs


yeah, i read that myself about an hour ago and i did a test with rclone mount.

the cloud file on the remote had a colon in the filename.
i was able to mount the remote, edit that file and save it no problem.

so what do you think is going on?

Each scanned title which contains: blocks the scanning of a plex library. Example title. Barry Seal: American Traffic (2017) .mkv After removing: in the title, the scan continues

2020/03/07 16:08:14 ERROR : worker-0 <Barry Seal : American Traffic (2017).mkv>: failed caching chunk in storage 0: open C:\Users\osx30\AppData\Local\rclone\cache-backend\gcache/Films/Barry Seal : American Traffic (2017).mkv/0: The syntax for the file, directory, or volume name is incorrect.

also, why does this have both foward slash and backwared slash?

I guess plex doesn't like the : character. Actually that is a normal ASCII : as is the one in the first post :confused: That certainly explains the problems.

When I try mounting I see the : replacement character, though Windows 10 doesn't seem to display it properly. What do you see?

I wonder if that is getting lost in translation through the cache maybe.


mount on windows displayed using double commander

mount on windows displayed using windows explorer

mount on windows dispalyed via command line

Has to be the colon, especially since he says Plex scans just fine once he removes it. Depending on how many files and folders are affected, a renamer like FileBot could possibly replace all colons with dashes, which is what's normally used in Windows. Major PITA, though :frowning:

the error that the OP posted, is a rclone error, not a plex error?
noticed that the file name has both forward slashes and backward slashes

2020/03/07 16:08:14 ERROR : worker-0 <Barry Seal : American Traffic (2017).mkv>: failed caching chunk in storage 0: open C:\Users\osx30\AppData\Local\rclone\cache-backend\gcache/Films/Barry Seal : American Traffic (2017).mkv/0: The syntax for the file, directory, or volume name is incorrect

I believe Windows knows how to handle the slashes. Plex, in fact, uses forward slashes in some of its own path settings. I still think the colon is the culprit, and Nick said it's an actual colon here, not the workaround version.

I wonder if OP did not use cache, would a Plex scan then proceed without errors on just the regular mount. My guess is yes, because the file system Gdrive uses obviously allows colons. It's the cache being local to Windows that throws the error due to an invalid character.

Sorry for the delay i had reached 20 comments per day

I removed the : on the name files and it works well this way! Otherwise the scan of the new library was blocked. Now I have another problem, I would have reached my quota of G-Suite per day only by scanning the files of the new library added. At least that's what rcone tells me and nothing is readable for now

2020/03/08 17:34:48 ERROR : Séries TV/Dr House/Dr House S03/Dr House S03E15.mkv: ReadFileHandle.Read error: low level retry 2/10: open file failed: googleapi: Error 403: The download quota for this file has been exceeded., downloadQuotaExceeded

quotas, sure proof we are in hell, not heaven,

quotas on rclone forum, as a new member.
quotas with gdrive, downloading too much.

reminds me of the song

quota, quota, everywhere a quota
Blockin' out the scenery, breakin' my mind
Do this, don't do that, can't you read the quota?

at some point soon, you will be able to download from gdrive again.

I tried to understand why I reached the quota of 10,000 requests just by scanning files. We are not talking about 750 GB of downloads or uploads. it's boring. one thing is certain, i reached it because i have the same error as much on mac as windows ...

I get the same download/API error every once in a while, but very rarely. What causes it in my case, I think, is that I have "Upgrade media analysis during maintenance" checked in Plex. This setting is a bit of a mystery to me, because I first checked it back in September, and it's been running every night from midnight until 8am since then. My library is large, but I'm pretty sure it should have long been done by now. Regardless, a normal scan, like yours, should never trigger this, unless, perhaps, it's part of an initial library scan. Make sure you have "Perform extensive media analysis during maintenance" unchecked.

This is indeed an initial analysis. It's a shame we are blocked for this but I must say that I did a lot of scan tests before correcting the names of my files. It becomes essential to have a clone or a back up of plex in case of theft or breakage otherwise with a large library recovery would be hell!

Renaming the target files was very fast, in fact on windows we saw: but on my macintosh we saw from / or \ instead. I did a search for / or \ with Google Drive File Stream on my mac in each main folder and I could easily rename the few targeted files!

1 Like

I read on another rclone topic that some people use v2. I do not know what it is exactly, but it is a topic of 2018 they seem to say that it goes faster with this rclone function, but also speaks of banishment on the part of google. What do you think? Otherwise what would be the command to launch by modifying rclone mount GSuite: x: --allow-other

On my mac Reading a file starts much faster, but I use the rclone mount command --allow-other --allow-non-empty remote: ~ / mnt / encryption --user-agent = "ams"
Scanning new libraries is also much faster with this command for crypt

Thank you!

It's faster because, wait for it..., it's NOT Windows! :wink:

No need for using v2 or anything else, really. Windows Explorer is extremely slow once you get into the thousands of files/folders. Nothing you can do, really, unless you're willing to switch to something else.

See my other post from this morning about creating folders for each letter. That will speed things up significantly.

sure, switch to double commander or pfrank

Thanks for your help. Finally my Mac is not that bad. Fortunately I can switch my pc to linux if necessary :slight_smile:

I do not know if it is me, may the scan under windows of new libraries create a lot of demand to google and we happen to have reached the quota fairly quickly. I never had this problem with my mac. I wonder if there are some things that I am not doing well. I know that there are several possible command to mount the disc maybe I do not use the most practical ...Do you have an idea to minimize the quantities of demand when adding a large library, a special order used among others? I use rclone mount GSuite: x --allow-other

Thank you!