Sync: Invalid or incomplete multibyte or wide character

What is the problem you are having with rclone?

Rclone Sync fails with "invalid or incomplete multibyte or wide character"

Run the command 'rclone version' and share the full output of the command.

rclone v1.64.0
- os/version: slackware 15.0+ (64 bit)
- os/kernel: 6.1.49-Unraid (x86_64)
- os/type: linux
- os/arch: amd64
- go/version: go1.21.1
- go/linking: static
- go/tags: none

Which cloud storage system are you using? (eg Google Drive)

SMB

The command you were trying to run (eg rclone copy /tmp remote:tmp)

while IFS= read -r user; do
echo "Backing up $user..."
  rclone sync -v \
    --fast-list \
    --log-file=$LOG_FILE \
    --progress \
    synology:/homes/$user/Drive /mnt/user/nextcloud/$user/files
done < <(rclone lsf synology:/homes)

Please run 'rclone config redacted' and share the full output. If you get command not found, please make sure to update rclone.

[synology]
type = smb
host = XXX
user = XXX
pass = XXX

A log from the command that you were trying to run with the -vv flag

2023/10/17 05:03:34 ERROR : Documents/ПРАВО/Наказателен процес/Обща част - 25 - Подсъдност на наказателните дела_Видове подсъдност.doc: Failed to copy: open /mnt/user/nextcloud/zkvvoob/files/Documents/ПРАВО/Наказателен процес/Обща част - 25 - Подсъдност на наказателните дела_Видове под�.gekegif5.partial: invalid or incomplete multibyte or wide character

Any ideas what I'm doing wrong, please?

Looks like problem writing to your destination - either path too long or characters issue IMO.

What is your destination? I guess it is something mounted?

You can try to run your sync with --inplace flag to see if it makes difference.

The destination is my Unraid server, from whence the script is being run. I can't substantiate this, but I'm fairly certain there are longer paths/filenames that work just fine.

At any rate, I'll try with --inplace and report back. Thank you!

EDIT: It works!

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.