Strange new file names appear after sync ($DATA )

STOP and READ USE THIS TEMPLATE NO EXCEPTIONS - By not using this, you waste your time, our time and really hate puppies. Please remove these two lines and that will confirm you have read them.

What is the problem you are having with rclone?

After a sync any folder names are created with the:$DATA added, ie a folder in my PGP directory called data has a 22b file created called PGP:data:$DATA, At first I deleted them but they have reappeared, Only happens on my encrypted sync

Run the command 'rclone version' and share the full output of the command.

rclone v1.66.0-beta.7604.1045f5412

  • os/version: debian bookworm/sid (64 bit)
  • os/kernel: 6.5.0-14-generic (x86_64)
  • os/type: linux
  • os/arch: amd64
  • go/version: go1.21.5
  • go/linking: static
  • go/tags: none

Which cloud storage system are you using? (eg Google Drive)

Google Drive

The command you were trying to run (eg rclone copy /tmp remote:tmp)

/usr/bin/rclone sync /media/PGP/ gcrypt:PGP/ --skip-links --backup-dir gcrypt:VersionsPgp/`date -I` --transfers=20 --drive-chunk-size 1024M --max-backlog 999999 --fast-list  --log-level NOTICE --log-file=/home/ard/Desktop/rc.log --exclude=/PGP/mail/** -P

Please run 'rclone config redacted' and share the full output. If you get command not found, please make sure to update rclone.

[gdrive]
type = drive
scope = drive
token = {"access_token""}

[gcrypt]
type = crypt
remote = gdrive:PGP
filename_encryption = off
directory_name_encryption = false
password = 123
password2 = 123
root_folder_id = abc

A log from the command that you were trying to run with the -vv flag

Paste  log here

Could you please provide some evidence? rclone ls gcrypt:PGP/path/to/problem etc.

Also include your sync command log with DEBUG output (-vv flag)

You do not have to provide all your data logs - create a test case with some small data subset.

tried with a test , worked fine
removed odd files from up both local drive & google drive, and everything looks good, No idea where they came from other than mounting the drives locally with rclone mount with this command
/usr/bin/rclone --vfs-cache-mode writes mount gcrypt: /media/Google/GooglePGP/ --cache-dir /media/MyData/rclone.cache1/

well... if they were in your local source then rclone did good job and synced them to your remote.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.