Speed test (rclone cache, plex drive)

I have tried using rclone cache and plex drive mount on a decent VPS. I have my media files stored in Google Drive. When I try to download files from plex, I get maximum speed. When I try to stream, I am facing buffering after every 10 seconds. I am not even transcoding, I am playing the original playback.

I have tried emby and plex but no luck with streaming!!!

The problem is not the bandwidth/throughput. The problem is that some mediaplayers (apparently including Plex in some cases) have a nasty habit of opening and closing the file it is reading frequently. This is a quite slow operation on most cloud remotes even though it is trivial on a local disk - leading to a situation where the player runs out of buffer because it's spending most of it's time opening and closing the same file instead of actually fetching data. Well known issue in general.

The good news is we have plenty of users who use Plex with rclone, so it is doable. I just don't use Plex myself (yet) so I don't know all the specifics. One other person I helped mentioned Plex had 2 different ways to play and that one of them worked fine? Does that tell you anything? I can't recall the exact details. I'll ask him tomorrow if this hasn't been solved by then.

Otherwise, take a look at Animosity's thread were he details a lot of this stuff. He runs Plex and has no issue - cache backend isn't even require with the right setup:

If all else fails you can gently nudge him for some help, but most likely the answers you need are in that topic and thread. Keep in mind he gets a lot of these same questions about Plex asked repeatedly (and a LOT of them will be in that thread), so please do your due diligence in researching before asking him to donate his time. He has the forums to moderate after all :slight_smile:

Thanks I am checking his repo if it will solve my problem and if it is not solved then maybe I can use that playing tip you said someone figured out :slight_smile:

Here's my source on this issue:

the problem I was having streaming 4K content though Plex is basically generated by the type of subtitles used in the filemost of the 4K movies files out there in either MKV or MPEG4 format have PGS formatted subtitles that requires transcoding
the only way to play a 4K file though Plex is by activating Direct Play and avoid any type of transcoding whatsoever

13:28ah, and direct-play is simply an option somewhere?

SKYPERBCN, 13:28yes Direct Play and Direct Streaming are two options available in the Plex settings

but if you want to stream 4K content on a sever with a fairly small processor like a NAS or something like that, you have to make sure that the subttitles are NOT in PGS format, otherwise that will trigger transcoding

He also mentioned that he had good performance using DLNA, but I'm not sure if he meant that was related to this spesific issue.

I get good performance using DLNA rather than a virtual mount. The video I was playing had 'UTF-8' text based subtitles and no PGS but i was facing buffering and stuttering on plex media player for windows and web app as well. I was playing in Original quality without transcoding.

I even tried to pause the video for some minutes but it didn't improve playback much.

Isn't there a way to play directly from cloud storage using rclone rather than a virtual mount?

You'd have to share your rclone version, mount command, debug log as noted in the question template as mounting and playing from Google Drive works without issue.

I have installed rclone with the script on this page:


my mount command:

rclone mount gcache: ~/mnt/gdrive --allow-other --cache-db-purge --allow-non-empty --buffer-size 64M --dir-cache-time 72h --drive-chunk-size 16M --timeout 1h --vfs-cache-mode minimal --vfs-read-chunk-size 128M --vfs-read-chunk-size-limit 1G &

I have rclone cache setup and I have followed instructions given on this page:


I don't want encryption or anything. I just want videos stored in my drive to play smoothly as I am playing them directly from the cloud. Thanks :slight_smile:

For debug log, can you please tell me exactly how I can pull that from Ubuntu?

Best to just include the output of rclone version:

felix@gemini:~$ rclone version
rclone v1.50.2
- os/arch: linux/amd64
- go version: go1.13.4

So it's easy to confirm rather than assuming.

The bytesized guide is somewhat awful imo and very dated as it mixes and matches concepts.

That's bad as it allows over mounting and has no real use case and should be removed.

Do you want to use the cache backend or no? I personally don't use it but if you do, you want buffer-size to be 0M as it uses it's own thing.

What's the reason you are using this?

My settings are shared in the previous post as I use a very basic command with majority of defaults as we pushed the majority of the good settings to defaults.

So my command looks like:

/usr/bin/rclone mount gcrypt: /GD --allow-other --buffer-size 256M --dir-cache-time 1000h --log-level INFO --log-file /opt/rclone/logs/rclone.log --poll-interval 15s --timeout 1h --umask 002 --rc --rc-addr

buffer-size is dependent on your server. I have plenty of memory so I pretty much waste a bit on the buffer size because I can. You can always remove that and start with the defaults.

The question template has that info in it on how to make a debug log:

A log from the command with the -vv flag (eg output from rclone -vv copy /tmp remote:tmp)

my rclone version:

rclone v1.50.2

  • os/arch: linux/amd64
  • go version: go1.13.4

and yes I would like to use your recommended command so what is the command to unmount? can you please remove those unnecessary parts from my command so i can push that in terminal without messing it up?

When i run rclone -vv copy /tmp remote:tmp i am getting following error

2019/11/21 14:46:53 DEBUG : rclone: Version "v1.50.2" starting with parameters ["rclone" "-vv" "copy" "/tmp" "remote:tmp"]
2019/11/21 14:46:53 DEBUG : Using config file from "/home/plex/.config/rclone/rclone.conf"
2019/11/21 14:46:53 Failed to create file system for "remote:tmp": didn't find section in config file

I wouldn't use the cache backend nor use your command at all. I'd use the command I shared with you.

That's an example command. With your mount command, you'd add "-vv" to it and that generates a debug log so you reproduce your issue and we can try to help debug it.

rclone mount gdrive: ~/mnt/gdrive --allow-other --cache-db-purge --allow-non-empty --buffer-size 0M --dir-cache-time 72h --drive-chunk-size 16M --timeout 1h --vfs-read-chunk-size 128M --vfs-read-chunk-size-limit 1G &

I have used this mount command now without cache so is it fine now?

As I noted above, I'd use this and not your command.

when i run your command

rclone mount gdrive: ~/mnt/gdrive --allow-other --buffer-size 256M --dir-cache-time 1000h --log-level INFO --log-file /opt/rclone/logs/rclone.log --poll-interval 15s --timeout 1h --umask 002 --rc --rc-addr

i am getting this error

Failed to open log file: open /opt/rclone/logs/rclone.log: no such file or directory

If you'd like to use a log file, you'd have to specify a location that exists on your system as a place to store the log file. So you'd modify that location to suit your server.

Ohh okay and without log file i am getting this error

Fatal error: Directory is not empty: /home/plex/mnt/gdrive If you want to mount it anyway use: --allow-non-empty option

The means you have items in that directory and you need to clean them up before you mount.

The mount folder should be empty.

Yes, you should definitely use a clean and empty location to mount to. Bypassing this with --allow-non-empty is not advisable unless you are absolutely sure of what you are doing. It can cause a lot of problems otherwise.

Okay let me delete all the files in this directory. Can you please help me with generating a log file that Animosity022 asked for? I don't know much about command line and this stuff.

I answered your other thread on that.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.