[Solved] Rclone Windows can't create socket for auth webserver even when Win fw disabled

Hi, just wanted to share this because it was not highly searchable

While trying to do an rclone authorize "backend" I was receiving

Failed to configure token: failed to start auth webserver: listen tcp 127.0.0.1:53682: bind: An attempt was made to access a socket in a way forbidden by its access permissions.

Even a just ssh -L localhost:53682:localhost:53682 user@server was returning an error when run as elevated Administrator:
bind [127.0.0.1]:53682: Permission denied channel_setup_fwd_listener_tcpip: cannot listen to port: 53682 Could not request local forwarding.

Windows Firewall was disabled and there were no firewalls in place.
I eventually found that this problem was because of my use of Hyper-V on the client machine. Hyper-V reserves the ports. This could possibly extend to people just using WSL2 but I haven't tested that aspect.

Longer term solution is here:

Short term solution is just to map a higher port, eg ssh -L localhost:63682:localhost:53682 user@remote

Anyway just wanted to share! Thanks, HTH.

1 Like