[SOLVED] Nginx + rclone google drive result in a 404 error (permission denied)

What is the problem you are having with rclone?

I'm using rclone to use my google drive as a virtual disk on linux debian 10 to store my websites files.
I've set permissions to 777 on the mounted folder but nginx still say that it does not have the permissions to access the path that is on the mounted rclone gdrive.

What is your rclone version (output from rclone version)

rclone v1.53.3-DEV

  • os/arch: linux/amd64
  • go version: go1.15.9

Which cloud storage system are you using? (eg Google Drive)

Google Drive

The command you were trying to run (eg rclone copy /tmp remote:tmp)

to mount my google drive as a disk

rclone --vfs-cache-mode writes mount drive: /var/www/html/gdrive/

The rclone config contents with secrets removed.

type = drive
scope = drive
token = {"access_token":"XXXXX","token_type":"Bearer","refresh_token":"XXXXXXX","expiry":"2021-11-09T13:51:37.995306229Z"}

A log from the command with the -vv flag

2021/11/09 13:46:07 [crit] 47215#47215: *241 stat() "/var/www/html/gdrive/websites/cdn.staffe.net/v1/management/tena>2021/11/09 13:46:14 [crit] 47215#47215: *251 stat() "/var/www/html/gdrive/websites/cdn.staffe.net/douyinpay.php" fai>2021/11/09 13:46:14 [crit] 47215#47215: *251 stat() "/var/www/html/gdrive/websites/cdn.staffe.net/site/get-hq" faile>2021/11/09 13:46:14 [crit] 47215#47215: *251 stat() "/var/www/html/gdrive/websites/cdn.staffe.net/site/get-hq" faile>2021/11/09 13:46:16 [crit] 47215#47215: *251 stat() "/var/www/html/gdrive/websites/cdn.staffe.net/index/Mobile/kline>2021/11/09 13:46:16 [crit] 47215#47215: *251 stat() "/var/www/html/gdrive/websites/cdn.staffe.net/index/Mobile/kline>2021/11/09 13:46:59 [crit] 47215#47215: *253 stat() "/var/www/html/gdrive/websites/cdn.staffe.net/XXX.png" fa>2021/11/09 13:46:59 [crit] 47215#47215: *253 stat() "/var/www/html/gdrive/websites/cdn.staffe.net/XXX.png" fa>2021/11/09 13:47:00 [crit] 47215#47215: *254 stat() "/var/www/html/gdrive/websites/cdn.staffe.net/XXX.png" fa>2021/11/09 13:47:00 [crit] 47215#47215: *254 stat() "/var/www/html/gdrive/websites/cdn.staffe.net/XXX.png" fa>

That's ancient version so you'd really want to update it.

You need to use --allow-other if you want another user than the one running rclone to see the files as that's how fuse mounts work.

Thanks for your reply !

All is now working properly. I marked topic as solved.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.