[Solved] Monitoring rclone bandwidth usage

What is the problem you are having with rclone?

I am not having a problem with rclone but with tracking the bandwidth rclone is using. We can monitor all bandwidth for a specific user with these iptables rules,
iptables -I OUTPUT -m owner --uid-owner username -j CONNMARK --set-mark 10
iptables -I INPUT -m connmark --mark 10

The above iptables rules monitor all in/out bandwidth (packets/bytes) for that user. However, when rclone is run under that same user the bandwidth is not tracked in the iptables packet/byte counters. I am not sure why this happens so I thought of asking for some ideas here.

What is your rclone version (output from rclone version)

rclone v1.51.0

  • os/arch: linux/amd64
  • go version: go1.13.7

Which OS you are using and how many bits (eg Windows 7, 64 bit)

Debian 10 x64

Which cloud storage system are you using? (eg Google Drive)

Google Drive

The command you were trying to run (eg rclone copy /tmp remote:tmp)

rclone copy /local/path remote:/path

You could use something like this:

1 Like

Is rclone going out ipv6?

1 Like

@calisro Thank you, totally forgot about IPv6!

1 Like

If you want to disable rclone using IPv6 then adding --bind should do it I think...

@ncw Thanks for listing that. In my case I just disabled IPv6 (since I have no real use for it) by adding this to /etc/sysctl.conf and running "sysctl -p"

net.ipv6.conf.all.disable_ipv6 = 1
net.ipv6.conf.default.disable_ipv6 = 1
net.ipv6.conf.lo.disable_ipv6 = 1

Hopefully it helps someone with the same issue.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.