[solved] Google teamdrive can't dedupe files

Hello Everyone:

I use AutoRclone to copy files to teamdrive, and find duplicate files.

You can check the file owner is different accounts.

I use the command to delete the files as this
rclone --config rclone.conf dedupe dst001:
but it not work.

I use the command as this
rclone --config rclone.conf ls dst001: >>log_rclone_ls.txt
to check the log and find there is NO duplicate files !!!

I don't know why ?

You need to run:

rclone dedupe dst001:

and that will clean up duplicates.

Can you post the result of rclone dedupe -vv dst001: ?

OK I solved the proble.

Use the normal account will run well.
Don't use the service account(SA) to do the rclone.

It depends on what the account has permission to. The account needs to be able to have the permissions to perform the function which is why it probably did not work as it couldn't see the the files.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.