Slow download from gdrive to local


#21

Speeds remain the same, unable to break that 100-150mbit mark from gdrive. Is this because I am using a crypt-ed drive? or VFS?


#22

BTW because of you, I now have an ATV on its way. This better fix my “stutter” issues. LOL!!! I kid.

Also, can you try a DIRECT transfer of one of your files to your computer, see what rate you get?


#23

Here is a 8GB file as an example copied from my rclone GD mount to my local HD.

felix@gemini:/gmedia/Radarr_Movies/Rampage (2018)$ du -ms Rampage\ \(2018\).mkv
7833	Rampage (2018).mkv
felix@gemini:/gmedia/Radarr_Movies/Rampage (2018)$ rsync --progress Rampage\ \(2018\).mkv /data
Rampage (2018).mkv
  8,212,716,732 100%   81.97MB/s    0:01:35 (xfr#1, to-chk=0/1)

I have gigabit Verizon FIOS so getting ~648Mb/s sustained transfer is pretty nice.


#24

Yup, I cannot go faster than 13-16mb/sec

Sure enough 830 PM PST hit and now I cannot download faster than 2-3mb/sec.

Speed test at my max speeds so it isn’t ISP.

It seems to be a peering issue during “congested” times. However during major times I am still unable to transfer at my max speed.

This is getting interesting.


#25

One thing you might want to try, depending on your expertise is leveraging Cloudflare if you are having peering issues.

This link is pretty good:

but I personally have been testing mine a bit as I use NGINX for everything so I just use a single IP and route everything through that.


#26

I should add that CloudFlare won’t sustain 80+mbps speeds for 4K stuff. It’s best to maybe use the reverse proxy on say a VPS that you can peer well with and have it go from your plex server > VPS > nginx > You. And if you are unable to block the Plex port using your firewall there’s a comment by me on that QuickBox forum on adding a variable in your Plex Preferences.xml to only allow localhost and disable all remote access since the enable remote access switch in Plex doesn’t work for custom ports (other than default 32400). :slight_smile:


#27

Did you have problems with that? I tested a few movies and played and didn’t see any issues with them playing.

Here is my example I just played for a few minutes:

image

That’s my highest bitrate movie.

Plex works fine for custom ports as you’d have to change the URL if you were using something custom.

Mine runs on my reverse proxy for 443.


#28

Tautulli can be inaccurate at times. It’s better to use PMP and hit control shift d to open up the debug info panel. On the right, you’ll see cache and above that bitrate. A good test to see if it’s able to stay consistently ahead of the media so no buffering will happen is to make sure direct play is on (Always resets to 20mbps when not using the TV interface on PMP) and scrub to a random part where there aren’t logos or dark scenes, then make sure it plays immediately without trying to buffer ahead. Watch the cache, if it stays consistently above 10 then you should be good to play it.

Also too, your reverse proxy, are you running it over CF as well or just your nginx server? You’ll likely need to block remote access to your plex port because clients can still access it even if you specify a custom url, you can test this by pulling down your nginx server so your plex would stop working since it should only be available through there, and then if you can still access the server through clients or plexweb, then the port is still accessible allowing people to bypass the proxy.


#29

Yeah, I was just using it as a benchmark. I have remote access disabled and blocked on my firewall as well so I’m sure it’s using CF properly.

My testing was CF->NGinx Reverse Proxy->Plex.

The movie I was playing has an overall bitrate of ~45Mb/s.


#30

It must be then that you have a fast connection. For those with a connection speed 50% or less higher than the target bitrate may have a hard time because sometimes CF can drop by half sometimes.


#31

Yeah, I’m gigabit FIOS so not bandwidth issues here. That’s good to know. Thanks.


#32

@ncw @B4dM4n The --drive-v2-download-min-size=0 was working great for me. Is this ever going to be implemented? I updated from 1.42 which I noticed doesn’t have this flag still.


#33

I seem to be having some slowness and I am not sure what is causing it. Any ideas?

I have 300/10 Mb connection.

here is my config.

[Unit]
Description=rclone cache
After=network-online.target
Wants=network-online.target

[Service]
Type=simple
ExecStart=/usr/bin/rclone mount plexcache: /home/plex/gdrive/plexcache \
   --allow-other \
   --dir-cache-time 48h \
   --vfs-read-chunk-size 48M \
   --vfs-read-chunk-size-limit 2G \
   --buffer-size 128M \
   --syslog \
   --umask 002 \
   --bind 192.168.2.120 \
   --log-level INFO
ExecStop=/bin/fusermount -uz /home/plex/gdrive/plexcache
Restart=on-abort
User=plex
Group=plex

[Install]
WantedBy=default.target

Sometimes I get 30MB/s, sometimes i get less than 2… what in the world.

plex@server:~/gdrive/plexcache/UHD Movies/Argo (2012)$ rsync --progress “Argo (2012).mkv” /tmp/
Argo (2012).mkv
173,834,240 0% 1.80MB/s 2:42:05 ^C

Here is what I get from plexdrive. they are both bad for some reason

plex@server:~/gdrive/plexwrite/UHD Movies/Argo (2012)$ rsync --progress “Argo (2012).mkv” /tmp/
Argo (2012).mkv
89,948,160 0% 2.64MB/s 4:55:45 ^C


#34

If you have multiple programs all getting poor speeds, odds are the problem is local to you. So bad peering, ISP issues, something along those lines.


#35

any news on this? should it be fixed with 1.42 ? or you still working on a solution?
because i still having unbelievable slow speeds with dedicated 1Gbit/s…

thanks


#36

What’s slow with 1.42? Here is a copy maxing my gigabit:

felix@gemini:/gmedia/Radarr_Movies/Unsane (2018)$ rsync --progress Unsane\ (2018).mkv /data
Unsane (2018).mkv
1,994,948,608 7% 100.30MB/s


#37

hm… okay… sorry then. took around 4hours to copy 200GB, but had not “–progress” enabled. thought it could be faster.


#38

Can you provide more information?

What’s your expectation on fast vs slow? What’s your bandwidth? What’s the command you were using? Can you share any logging/debug of when it was slow? Is your system CPU bound when it happening? Is it copying from a disk that’s IO bound? Is there someone else consuming your bandwidth when the copy is going on?


#39

I have the exact same problem and have verified that it is not peering. I have a gigabit link and with rclone versions 1.39 and older can nearly max out the gig link. With >1.39 (drive v3 api), I can barely sustain 4.5MBps. My rclone mount setup can’t stream 4k either because of this bandwith constraint and I see that the test build to alleviate this has been removed.

Edit: I found the test build here: https://beta.rclone.org/branch/v1.41-075-ga193ccdb-drive_v2_download/)

I’ve ensured that my system is not constrained with IO or CPU usage.


#40

Can you share some information? How are you testing? Can you provide some samples/logs?