Setting a high max-read-ahead

What is the problem you are having with rclone?

Is setting a high max-read-ahead a bad idea?
I set mine to --max-read-ahead 1G to play movies as fast and fluid as possible

What is your rclone version (output from rclone version)


Which OS you are using and how many bits (eg Windows 7, 64 bit)


Which cloud storage system are you using? (eg Google Drive)

Google Drive

The command you were trying to run (eg rclone copy /tmp remote:tmp)

rclone mount

That is a hint to the kernel that rclone passes along - not a hard enforceable setting. Most OSes (including Linux) will simply ignore it above 128k. To put it simply - you can't really use that setting to achieve your goal. You may use the cache backend or simply set the buffer to however much you prefer in the video player directly.

Are you experiencing stuttering?

No stuttering, I just want to play(start/seek) videos and music as fast as possible. Just looking for tweaks

And how fast do you start/seek your typical media with your current settings?
1-2 seconds is kind of unavoidable due to latency of requests. If it's close to this there may not be all that much more you can do, but if it is significantly more then maybe.

yeah its like a second usually

That does nothing unless you plan to custom compile a kernel.

That seems pretty good then honestly. There are some inherent limitations due to latency of requests that means you will never get the same responsetime on a clouddrive as you would on a local drive - no matter what settings you use. I don't realistically think there is much you can do to get it below a second - unless you use a cache and the start of the file is already in cache obviously - but that's not really a "solution" to that problem.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.