Sending files to S3 with "cache-control" header set

What is the problem you are having with rclone?

Cannot set metadata

What is your rclone version (output from rclone version)

rclone v1.45

  • os/arch: darwin/amd64
  • go version: go1.11.2

Which OS you are using and how many bits (eg Windows 7, 64 bit)

Mac OSX, 64

Which cloud storage system are you using? (eg Google Drive)

S3 Amazon

The command you were trying to run (eg rclone copy /tmp remote:tmp)

rclone copy myfile s3:mybucket/

A log from the command with the -vv flag (eg output from rclone -vv copy /tmp remote:tmp)

No log needed

My question is simple: while sending the file to S3 buckets, how can I also assign some metadata like cache-control: max-age=86400? Thanks.

Alas, this isn't possible at the moment.

However there is an issue about it here:

And a related one here:

I'd love some help with this if you had some time to work on it?

It’s sad that this isn’t built into rclone. Makes it useless for anything other than backup. AWS-cli and s3cmd both have this inbuilt. I’d like to use rclone if possible just because I could do this with both s3 and google drive. Hope they implement this basic functionality in the future.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.