ScummVM with rclone mounts = not able to list content

That indicates you are running rclone as root. Run it as a normal user with the --allow-other flag and hopefully it will work better.

Running fuse filing systems as root isn't recommended.

1 Like

I will see what I can do, but I have low expectation that LibreElec allow me to create new user.
LibreElec is a just enough OS for Kodi where every user binaries runs as root.
To be more precise, I do use the retroarch kodi addon, which run as root as well.
RetroArch is a front end to various cores (think shared object libraries for various emulated systems), so all the cores run using the same user / environment (ie, root). All the front end, cores can browse the rclone mounts, only the scummvm core can't, so I'm really suspecting scummvm being the issue here.
Alos, I do mount my remotes using systemd mount units, I don't see how i can tell it to use a specific user.

I do have a mac machine, I will have a test on that as well.

In the service file, you just put the user and group.

An example snippet of mine:

ExecStopPre=/bin/fusermount -uz /media/TV
ExecStopPre=/usr/bin/fuser -kMm /media/TV
ExecStop=/bin/fusermount -uz /media/TV
ExecStartPost=/usr/bin/rclone rc vfs/refresh recursive=true --rc-addr 127.0.0.1:5575 _async=true
Restart=on-failure
User=felix
Group=users

Unfortunately, it looks like I can not create a new user, see Support to create a new user to make SSH or to conect via samba from windows - General Support - LibreELEC Forum

The way fuse mounts generally work is only the user running them can see the content.

Using allow other generally requires an edit to the /etc/fuse.conf to make that work.

felix@gemini:/etc/systemd/system$ cat /etc/fuse.conf
# /etc/fuse.conf - Configuration file for Filesystem in Userspace (FUSE)

# Set the maximum number of FUSE mounts allowed to non-root users.
# The default is 1000.
#mount_max = 1000

# Allow non-root users to specify the allow_other or allow_root mount options.
user_allow_other

If the user running it can see stuff though and it's running as the same user as the mount, there should be no issue with that. You'd generally see access denied in trying to navigate into the mount.

To me, your issue feels specific to the OS and/or how that interacts with that ScummVM app as it seems to work without issue on my Mac as I can see files which is enough to validate the mount is working.

I don't have a PI to see what happens there nor much familiarity with that OS and how it's installed/works.

Yep, will start to investigate the scummvm core side. Thank you.

on windows, no problems.

in fact i am running scumm.exe direct from the cloud.
the .exe is not stored on my local computer.

rclone.exe mount wasabi01:scumm b:\rclone\mount\scumm --file-perms=0777

For what I recall, rclone has 3 backends, macos/windows do not use the linux one.
I'm investigating the scummvm side, I will also try to reproduce the issue on another machine / device.

I tracked it done to the scummvm retroarch backend... It was not built with large file support and resulted in overflow from readdir.
So it's fixed, and not rclone related.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.