Scheduling a bat file which uses rclone

The system cannot find the path specified.

so i was correct about what i wrote above.
you are running rclone.exe with admin righs and windows explorer is run without admin rights.
so windows explorer and a non-admin command line cannot see the mount

there is a good reason, windows is doing what it is doing
to understand the problem and a workaround i would not suggest.

the workaround i would suggest is to run rclone.exe as system user.
then the mount will be visible to programs run as admin righs and run as non-admin rights.

1 Like

hey man you were right...thanks for the solution man

and rplying to all my silly questions

glad to help you

1 Like

hey bro one more thing if i run the mount command via admin cmd and explorer cant see it then why can the explorer see the mount if i run it via task scheduler with "highest privileges".

i understand the confusion

as per the link i shared above, there are two sessions per window user.
"When UAC is enabled, the system creates two logon sessions at user logon. Both logon sessions are linked to one another. One session represents the user during an elevated session, and the other session where you run under least user rights."

windows explorer runs under least user rights.
task scheduler with "highest privileges" runs as elevated / admin rights

so windows explorer cannot see anything from an elevated session.
and this is one reason i have not use windows explorer in over 10 years.

1 Like

Windows really is confusing.....specially the task scheduler part where "highest privilege" session can be seen by's kind of a mess if you ask me.:confused:

...and what do you use as alternative for windows explorer?

in this situation, think of windows as a schizophrenic with two personalities existing at the same time.
one personality cannot see the other.

i use
and, like me, i know you like portable apps.
another reason i do not use explorer is that there is a awesome free version of windows server 2019 i use at home, at my office and all my customers. windows server 2019 hyper-v edition
it is command line only, no desktop, no icons, no windows explorer.
and in that limited command line version, double commander runs fine.
in addition there is a linux version i use.

1 Like

I'll give this program a shot ....btw thanks for taking out some time of your day to solve my problem.......rclone imo is so awesome premium stuff and so many good features in one package......

I think more people should use it ...just the command line interface scares off many people..and that imo is a shame man

yeah dude it is a crying shame :sleepy:

one more thing, you can donate to the primary author of rclone
i assure you that i do not profit financially, but i do profit spiritually.

I sure will donate to this project man

1 Like

And bring some more people here...just the fact that a medical student can use this progam will convince many people to use it .....maybe idk

Still can't believe I'm doing all this just to sync a few mb of files and some gamesaves.....looks like I really like to take the long cut lol

It was worth it tho..I learnt a lot of new things.

i am computational doctor and i often diagnose patients suffering from clickatosis.
clickatosis, or in the common vernacular, click-crazy.
patients development an uncontrollable need to:
click on this icon
click on that link
over and over

the cure is to proscribe a dose of the command line
the vitamin rclone.

rclone, taken each day is the cure to clickatosis.

1 Like

Even I used to be scared of cmd...the. I decided to do basic stuffs from cmd like copy extract etc etc....I'm really enjoying it :slight_smile:

I hv already dual booted linux....hope to learn linux properly too

no need to dual boot.

  1. run linux in a hyper-v virtual machine.
  2. better yet, if you are running win10.2004.64bit then use WSL.