Saving bucket name in rclone config?

What is the problem you are having with rclone?

I am creating buckets in our universities S3-like server for various projects.

Rclone is working very well for file transfers. On issue I am having is that I always have to specify the long bucket identifier for copying. I was wondering if there is a way to configure rclone to remember the bucket name for every remote.

It is a little bit annyoing that I have to look up the bucket name every time.

Run the command 'rclone version' and share the full output of the command.

rclone v1.65.2

  • os/version: rocky 8.9 (64 bit)
  • os/kernel: 4.18.0-513.11.1.el8_9.x86_64 (x86_64)
  • os/type: linux
  • os/arch: amd64
  • go/version: go1.21.6
  • go/linking: static
  • go/tags: none

Which cloud storage system are you using? (eg Google Drive)

Amazon S3-like

The command you were trying to run (eg rclone copy /tmp remote:tmp)

Works:

rclone copy my_remote:/32f1315-14ab-4283-b557-d54e557ac3/target_folder .

Does not work:

rclone copy my_remote:/target_folder .

Please run 'rclone config redacted' and share the full output. If you get command not found, please make sure to update rclone.

[my_bucket]
type = s3
provider = Other
access_key_id = XXX
secret_access_key = XXX
endpoint = https://XXX-s3-01.s3.xxx.com:9021
acl = private

A log from the command that you were trying to run with the -vv flag.

>rclone copy my_remote:/target_folder .
2024/02/01 17:35:18 ERROR : S3 bucket my_bucket: error reading source root directory: directory not found
2024/02/01 17:35:18 ERROR : Attempt 1/3 failed with 1 errors and: directory not found
2024/02/01 17:35:18 ERROR : S3 bucket my_bucket: error reading source root directory: directory not found
2024/02/01 17:35:18 ERROR : Attempt 2/3 failed with 1 errors and: directory not found
2024/02/01 17:35:18 ERROR : S3 bucket my_bucket: error reading source root directory: directory not found
2024/02/01 17:35:18 ERROR : Attempt 3/3 failed with 1 errors and: directory not found
2024/02/01 17:35:18 NOTICE: 
Transferred:              0 B / 0 B, -, 0 B/s, ETA -
Errors:                 1 (retrying may help)
Elapsed time:         0.0s

Thank you for your help!

do not put "/" between remote name and path:

my_remote:32f1315-14ab-4283-b557-d54e557ac3

is the right way.

As per docs:

Paths are specified as remote:bucket (or remote: for the lsd command.) You may put subdirectories in too, e.g. remote:bucket/path/to/dir.

Perfect, thank you!

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.