S3: using wrong location constraint

What is the problem you are having with rclone?

rclone cannot list my s3 bucket

I got an error about eu-central-1 location constraint but I'm using eu-south-1

Run the command 'rclone version' and share the full output of the command.

rclone v1.67.0
- os/version: darwin 14.5 (64 bit)
- os/kernel: 23.5.0 (arm64)
- os/type: darwin
- os/arch: arm64 (ARMv8 compatible)
- go/version: go1.22.4
- go/linking: dynamic
- go/tags: cmount

Which cloud storage system are you using? (eg Google Drive)

AWS S3

The command you were trying to run (eg rclone copy /tmp remote:tmp)

rclone ls s3-bucket:

The rclone config contents with secrets removed.

[s3-bucket]
type = s3
provider = AWS
access_key_id = AKIAU....
secret_access_key = YgSJ......
region = eu-south-1
location_constraint = eu-south-1
acl = private
server_side_encryption = aws:kms
storage_class = STANDARD

I tried adding

- endpoint: s3.eu-south-1.amazonaws.com

from this page: Amazon Simple Storage Service endpoints and quotas - AWS General Reference

But I'm getting the same error

A log from the command with the -vv flag

2024/07/04 17:37:00 DEBUG : rclone: Version "v1.67.0" starting with parameters ["rclone" "ls" "s3-bucket:" "-vv"]
2024/07/04 17:37:00 DEBUG : Creating backend with remote "s3-bucket:"
2024/07/04 17:37:00 DEBUG : Using config file from "/Users/mirkotebaldi/.config/rclone/rclone.conf"
2024/07/04 17:37:00 DEBUG : 7 go routines active
2024/07/04 17:37:00 Failed to ls: IllegalLocationConstraintException: The eu-central-1 location constraint is incompatible for the region specific endpoint this request was sent to.
	status code: 400, request id: QSPJ6CSADDM217GK, host id: lqsjDcqTTV+VOltuaqN/5RS1BS53rOKxRnN5tax/Csz40pM5u8cIfuHllGFrvgaUw5QsqxQcIct+djpwCC5udMABEw5dlmzK