[RESOLVED] All of a sudden googleapi Error 429

My DNS error was just a 1 time thing and never saw it again in my logs. I normally don't run with DEBUG anymore these days.

It wouldn't be a DNS item as all my requests are getting to the Drive API as they are showing errors in the console. My guess would be something on Google end is misbehaving, but not sure how to check that as all the status pages I can hit are green and show no issues.

I tried to get support through GSuite and they don't do the APIs. Trying to get support for the APIs is proving to be tougher than I'd imagine as I can't seem to find the proper path for that.

1 Like

Ah, fair enough.

Hmm, that's interesting. My company GDrive account is also exhibiting these issues, so it's certainly looking like an issue on Google's end and nothing to do with Plex usage etc.

Here's hoping that it's resolved fairly soon!

www.googleapis.com page shows just "Not Found". Their server must be down.

Yeah, I think at this point, I'm going to ignore and see if it clears up on its own as I don't believe the issue is on our side at all. I checked my usage and my pattern of hits hasn't changed at all. I barely hit 100-120 hits per 100 seconds which is well below the 1000 per user.

Yeah seems to be an issue at Google itself. Haven’t heard complains yet and streaming seems fine when I tested it. Most of what’s being played is local anyway, so its not an usual API issue.

working for me again now :slight_smile:

well i take that back... it is working but i'm still getting the errors : (

(using 3 connections)

1 Like

Not much info to add, but I've been experiencing this off and on forthe last 2-3 weeks. I have tried so many things and different rclone settings/arguments but nothing has fixed it. Some days are worse than others, but tonight it's the worst I've seen it.

Uploading is totally not working, not getting errors in the logs though.

Strange thing is, I have mounts with plexdrive, no problems. Upload with rclone is not possible, but Odrive works like a charm. Same Account.

Hmm, after setting my plexdrive mount to verbose, I get some 403 but not as much as rclone.

According to reddit (https://www.reddit.com/r/DataHoarder/comments/boo9pd/is_anyone_else_getting_rate_limited_by_google/) this seems to be an issue affecting only european users (which I am indeed). There is an american user that says that everything is fine for him.

Are all of us in this thread from Europe?

I'm from Europe, yes

I'm in Europe also.

Yup also in europe

my issues are from my European server as well. my rclone works fine from home located in north america.

Europe here too.

Yep. Like you, the aforementioned reddit user claims that he can upload fine from US, but gets the infamous 429 error when uploading from Europe (using a VPN or something like that I guess).

whats weird is with sonarr/radarr pointed to my rclone mount it uploads. and whats even weirder is sonarr/radarr shows the item as uploaded. but then gdrive of course lacks the file and when you refresh the drive it poofs. probably just a false flag on sonarr/radarrs side.

glad i found this thread and the reddit thread. i was going crazy. even rebooted a few times.

1 Like

Well...

I fired OpenVPN and I'm connecting from Houston, TX right now.

Guess what... still 429 Rate Limit Exceeded on 2 different totally unrelated accounts.

Edit: Those 2 accounts were already 429'd. Tried a non-429'd third account and also got 429.

So is universally spread?

weird. i was finally able to get a file to upload and stick though. 1 file. out of a lot. ugh.

Is anyone using Hetzner servers?