Reduce Poll interval

I use rclone mount to mount s3 bucket, i need to poll the files once uploaded to s3 from any other source, but rclone takes time to see the uploaded files
-what is the default rclone time to see the uploaded files from other sources.

-how to reduce this time or see the file once uploaded

hello and welcome to the forum,

s3 does not support polling.
there are some ways to work around that.
but most s3 providers charge per api call and so it can get very expensive.

when you posted there was a template of questions, which if you had anwered, would help us to help you with a quality answer.

1 Like

I used the flag "--poll-interval 2s" and it worked fine, will this cost more money?

if it worked fine, then what is the problem?

s3 remotes do not support polling, as per a debug log.
S3 root: poll-interval is not supported by this remote

Yes, you are right.
I can see in the logs that "poll-interval is not supported by this remote".
and it works now, it seems that it was a network issue or slow internet connection.

Thanks a lot.

1 Like

sure, glad to help.

I don't know why but it works some times but most of the times it can't find the file, any idea why?

rclone version rclone-v1.55.0-windows-amd64
windows server 2012 - R2 - 64 bit
I use AWS s3
the command : mount remote:XXXX x: --volname workbooks --fast-list -o --UserName=Everyone --cache-dir=D:\ --vfs-write-back=0 --vfs-cache-mode=writes --log-file RCloneLogs.Json --log-level ERROR --use-json-log --config "C:\rclone\rclone.conf"

I added the flag --dir-cache-time=1s and it worked, is there a side effects for this in terms of money and performance?

--fast-list does nothing on a mount.

in terms of money, aws s3 charges per api call, so it will cost you.
you would need to login to aws s3 portal and check.

i use aws s3 only for deep glacier storage.

for any thing else i use wasabi, a s3 clone, known for hot storage, that does not charge for api calls.