Recommended Dropbox (Formally Google Drive) and Plex Mount Settings

this guy is implying that the jellyfin bug is your mergerfs settings. might it be possible? https://github.com/jellyfin/jellyfin/issues/2276#issuecomment-574004082

Jellyfin is pretty much the same thing as Emby (at a high level as it was what it was based on). Which both do the same things as Plex.

I can't use direct_io as I use torrents so that would break torrenting on the mount.

Not sure what it meant by non_empty as that's the same reason for me for not over mounting things.

It looks like they have an old version as they have many old options set that are replaced and a ton of defaults that aren't needed. Would doubt it is my mergerfs command or rclone command but you'd rule that out by checking the logs for each and seeing what's going on when the issue happens.

Is it possible to see the contents of this with rclone?

Yes, with something like:

rclone ls GD:  --drive-trashed-only

You can even mount with:

felix@gemini:~$ rclone mount GD: /Test --drive-trashed-only
1 Like

I'd suggest to make a new post as this has nothing to do with my settings as you aren't using them. Use the question template and ask there rather than hijacking my thread. Thanks!

any special reason jelyfin/emby seek through videos on direct stream faster than plex does?

Not sure I'm following the question.

If I'm direct streaming, it's either playing or not. I have no issues direct playing from Plex or Emby. Both work with no issues for me.

My use case tends to be watching TV or a Movie so I rarely seek. I've done some ad hoc testing and found just about no different between Plex or Emby.

Emby/Jellyfin have no HDR support on ATV for direct play so that's a deal breaker for me.

If you have a separate question about something other than my settings, you can always make a new post and other folks can chime in on your question and provide their feedback as well.

well direct olay doesnt work on browser which is what i use but that isn't what i'm asking/talking about

my question is more about the fact that when i skip/seek through video on plex(direct stream) its slow but when i seek/skip through video on emby/jellyfin(direct stream) it's fast.

wondering why that is.

Your best bet would be to open a new post, share your settings, versions and a few debug logs from each and I'm sure we can shed some light on it.

How often do you play content from Plex in web browsers?

Never.

I use ATVs in my house, iPhones and the native Plex App if I had to slum it and watch on a computer.

Hi @Animosity022,

I'm using some of your scripts in my build but I face an issue when radarr is getting a newer version of a movie: once the grabber has complete the download, radarr cannot access the first file to delete it I assume: I got an access denied in radarr log when importing the movie.

**Couldn't import movie /downloads/xxxxxxx.mkv: Access to the path "/movies/xxxxx (2016)/xxxxx.mkv" is denied.**

My radarr is running in a docker with the volume /movies/ (in the container) mapped to my host folder /gmedia/. This folder is mounted with mergerfs and has the following structure:
/gmedia/
/temp/ => local path on my host where all media freshly grabbed are stored
/gmount/ => gdrive mount (crypt & cache)

when I do ls -l to check ownership of files in docker and on my host, all files are owned by root -rw-rw-r--

Do you have any idea what more can I check ?
Thank you

Sorry @Plouf as I don't use dockers at all as I find them unneeded as I run all on a single machine. They only add unneeded complexity for me.

Sounds like you are having a permissions issue related to the docker setup.

understand
There is one thing i want to confirm: with your scripts, radarr can delete a previous version of a media and replace it by a better one ? let's say it deletes a 1080p and replace it by a 4k version ?

Yep. I do that all the time.

My rclone mount is read/write so it deletes from the rclone and it's replaced on the local disk. Works like a champ as that's one of the main use case setups I was trying to solve.

ok, I will investigate.
I wonder if I should change umask 002 in rclone mount command to 022

Seems to be ok now. Ive changed my docker container to run as root

Hi @Animosity022,
Thank you for your work firstly. It look exactly what I am looking for and wish to use unlimited gdrive account I have for my Plex. As of now I am using Synology DS218+ with Sonarr/Radarr/NZBget on dockers and store everything locally but want to move to the gdrive. I tried to mess around a bit with my Synology and have got the rclone installed and working with gdrive already mounted. But I am not too tech savvy to understand all the codes you have on github. I have read them a lot and just dont know where to start as yours is on a different Linux system. Can you help me? Also is it possible to do what you are doing on a Synology with running everything on DSM? Thanks.

Sorry as I am not familiar with Synology/DSM.

I'd suggest to just make a new post as I know a few users here have that setup and use that and just ask if you have any specific questions or issues you are facing.

I have worked out most of the basics and stuck on the mergerfs command. I have a local drive that Sonarr/Radarr writes to and then I have mounted Gdrive and want to fuse them together to something say gmedia. This is my command. Can you please help?

mergerfs '/volume1/Plex Database':/volume1/homes/admin/gdrive /volume1/gmedia -o nonempty,rw,sync_read,use_ino,allow_other,func.getattr=newest,category.action=all,category.create=ff,auto_cache,dropcacheonclose=true

I know that you had some issues with getting this to work with the >2.55 version of mergerfs. I have somehow managed to get the following version
FUSE library version: 2.9.7
fusermount version: 2.9.4
using FUSE kernel interface version 7.19
Any help is appreciated.