ReadFileHandle.Read error when copying and reading from sharepoint mount

What is the problem you are having with rclone?

I was able to mount SharePoint site documents on my linux server and I can see them in my mounted directory.
The issue is appearing when trying to copy/read from the mount point - I get a lot of those errors:
ReadFileHandle.Read error: low level retry 1/10: EOF
ReadFileHandle.Read error: low level retry 8/10: 416 Requested Range Not Satisfiable
Important to say : the copy operation works and the file is in the dest dir and the read works also, but the errors keep printing.
File type : office (xls and docx )
I tried to read about this issue but didn't find any solution.
When using rclone copy from the remote directly to my dir it works fine ( but my issue is doing cp from the mount itself).
mount command:
rclone --vfs-cache-mode writes --gid 10025 --umask 027 mount sharepoint: /sharepoint_dir --allow-other --ignore-checksum &

What is your rclone version (output from rclone version)

rclone v1.54.1

  • os/arch: linux/amd64
  • go version: go1.15.8

Which OS you are using and how many bits (eg Windows 7, 64 bit)

Red Hat Enterprise Linux Server release 7.5 (Maipo) 64bit

Which cloud storage system are you using? (eg Google Drive)


The command you were trying to run (eg rclone copy /tmp remote:tmp)

cp /sharepoint_dir  ~mzborovsky/

The rclone config contents with secrets removed.

type = onedrive
region = global
token = {"access_token":""}
drive_id = ""
drive_type = documentLibrary

A log from the command with the -vv flag

no log because its not a rclone command 

Please help, will appreciate it a lot

hello and welcome to the forum,

might try --ignore-size

Thanks for the fast reply!
Tried that flag earlier in the mount command but it didn't helped and I had the same errors.

if only copy files, not open/edit, perhaps test without --vfs-cache-mode

Still same error also when disabling it.
The strange thing that the copy does work but the errors still printing...
Any other suggestions ?

I updated the rclone version now to 1.55.0 and another error added to the same command run:
vfs cache: failed to download: vfs reader: failed to write to cache file: 416 Requested Range Not Satisfiable. I still can read and copy the files but errors keep printing

based on your first post, you were already getting that error,

Find out what the issue was.
The directory contained old version of excel (xls) and probably the software doesn't know how to handle it. When I changed it to xlsx it copied it without any errors.
Thank you for your help!

good to know that workaround

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.