Rclone - Windows help


#1

So im really new to rclone im mainly using it to mount my gdrive with windows for plex. Now i’m not using rclone to send files to the cloud mainly just read whats on there already.

but when i scan my library it seems super super slow and after awhile it locks up my connection and plex becomes unreachable.

I have skimmed the forums for awhile now and tried out a few things but nothing seems to help.

i have setup api id and have the credentials in rclone config

i using this for mounting

rclone mount gdrive: W: --allow-non-empty --allow-other --size-only --timeout 1h --dir-cache-time 2m --vfs-cache-max-age 72h --vfs-read-chunk-size 64M --vfs-read-chunk-size-limit 5G --drive-chunk-size 128M --buffer-size 64M --config “C:\Users\Administrator.config\rclone\rclone.conf”

I did a scan 13 hours ago and left it running over night. I now see it has only put 5 shows on plex out of like 200 lol.

I really dont know what else to do. im sure the mount script im using has some issues but really im unsure as i just used what someone else told me to use.

Windows Server 2016
Dual Xeon x5670
16 gigs ram


#2

rclone version is what?

Do you see anything in the logs? You might want to turn them on to see what rclone is complaining about or what isn’t working.

–dir-cache-time 2m should be something like 24 hours or something much larger as 2 minutes is way too small.


#3

ok i shall change that to 24 hours, i’ll look to see how to enable logs and post it after i rerun the scan. Give me 5-10 mins for that reply

c:\rclone>rclone version
rclone v1.46

  • os/arch: windows/amd64
  • go version: go1.11

#4

I’m on Server 2016 as well, and after a lot of experimenting I found that keeping the mount as simple as possible works best. Here is what I use (thanks to @Animosity022):

rclone mount --allow-other --dir-cache-time 96h --read-only --timeout 1h -v


#5

–dir-cache-time 2m should be something like 24 hours or something much larger as 2 minutes is way too small.

Changing this to 24h has solved my issue :slight_smile: ty so much man