Rclone vfs cache: failed to reload item:

Hi. I needed to unmount the RCLONE drive to move to a new folder mount location. I ran the following command: # fusermount -uz /path/to/local/mount

I then went to remount by using: rclone --vfs-cache-mode writes mount "onedrive": /OneDrive

I immediately got the following error:

rclone vfs cache: failed to reload item: reload: failed to add virtual dir entry: file does not exist

After showing this error for a multitude of times, the terminal window then froze up. I closed the terminal window and then tried to remount via a new terminal window but could not get it to work.

I've read that I may need to reboot the system to fix the "cache" problem. Is there a way to simply restart rclone itself or an alternative solution to fix this problem that does not require a system reboot?


Make sure rclone is stopped with the fusermount command, then check with ps ax that there are no rclone processes.

Restarting rclone then should be OK.

If not you might need to stop rclone and remove the cache - rclone config paths will show you where the cache is.

I did unmount the drive using fusermount. I checked for any running processes using rclone but did not find any. So I reran: # rclone --vfs-cache-mode writes mount "onedrive": /OneDrive

But have no success. The terminal window just hangs up and I need to use Ctrl C to quit the command. Doing so, I get the following error: ^C2022/01/25 15:38:17 ERROR : /OneDrive: Unmounted rclone mount

Any thoughts?

Best bet would be to make a new post and fill out the help template.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.