Rclone upload speeds suddenly dropping to 50k/s to B2

What is the problem you are having with rclone?

After a certain amount of time, My upload to Backblaze's B2 drops from 100Mbps to just a mere 50k/s

What is your rclone version (output from rclone version)

rclone v1.52.1

Which OS you are using and how many bits (eg Windows 7, 64 bit)

Debian, 64-bit

Which cloud storage system are you using? (eg Google Drive)

Backblaze B2

The command you were trying to run (eg rclone copy /tmp remote:tmp)

rclone copy --log-file=/var/log/rclone/backup-$NOW.txt --log-level INFO /srv/dev-disk-by-label-2TB/FTPBackups/$NOW.7z b2:BACKUPS/FTPBackups/
(This is a bash script, hence the $NOWs)

The rclone config contents with secrets removed.

type = b2
account = REMOVED
hard_delete = false

This in my logs shows the sudden drop to just 50k/s

2020/06/28 12:10:23 INFO  :
Transferred:        1.930G / 2.081 GBytes, 93%, 10.984 MBytes/s, ETA 14s
Transferred:            0 / 1, 0%
Elapsed time:      2m59.9s
 *                                Jun-28-2020.7z: 92% /2.081G, 11.670M/s, 13s

2020/06/28 12:11:23 INFO  :
Transferred:        1.996G / 2.081 GBytes, 96%, 8.521 MBytes/s, ETA 10s
Transferred:            0 / 1, 0%
Elapsed time:      3m59.9s
 *                                Jun-28-2020.7z: 95% /2.081G, 425.839k/s, 3m27s

2020/06/28 12:12:23 INFO  :
Transferred:        1.999G / 2.081 GBytes, 96%, 6.825 MBytes/s, ETA 12s
Transferred:            0 / 1, 0%
Elapsed time:      4m59.9s
 *                                Jun-28-2020.7z: 96% /2.081G, 51.659k/s, 27m36s

I'm not too sure if I'm supposed to use extra arguments or its Backblaze, I've checked my current bill and it doesn't show any kind of caps or limits being reached. In addition, no other downloads have begun on the same machine. The machine has a direct connection to the internet and does not use any wireless connections. It seems that every time the file upload is about to come to an end, the upload speed just drops suddenly and this keeps happening until I kill the task and start the transfer again manually.

I can't think of anything obvious.

Could it be your ISP doing throttling?

You could try setting a --bwlimit to slow the transfer a bit, maybe it will need more consistent like that.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.