Rclone union/FTP mount refresh

What is the problem you are having with rclone?

I am trying to create a mount with one local folder and one ftp remote together as a union. It works, except I can't see new files created on the remote. It's not "refreshing" the remote until I restart the mount. Other than that, everything works as expected.

How I would like it to work: ServerA has ServerB as an FTP remote. ServerA also has a union containing the local folder /opt/unionmount (readonly) and ServerB (FTP). When I mount the union remote, new files created on ServerA's mount path should be stored on ServerB. But it should read files from both ServerB and the local folder /opt/unionmount. If files/folders are created on ServerB, ServerA should update the remote periodically (or however it works) so it becomes aware of the new files/folders.

Any help would be much appreciated.

Run the command 'rclone version' and share the full output of the command.

rclone v1.62.2

  • os/version: ubuntu 22.04 (64 bit)
  • os/kernel: 5.19.0-50-generic (x86_64)
  • os/type: linux
  • os/arch: amd64
  • go/version: go1.20.2
  • go/linking: static
  • go/tags: none

Which cloud storage system are you using? (eg Google Drive)

FTP (vsftpd)

The command you were trying to run (eg rclone copy /tmp remote:tmp)

Description=RClone Service FTP

ExecStart=/usr/bin/rclone mount \
  --config=/opt/rclone/rclone.conf \
  --log-level=INFO \
  --log-file=/opt/rclone/logs/rclone-mount-ftp.log \
  --umask=002 \
  --gid=1000 \
  --uid=1000 \
  --allow-non-empty \
  --allow-other \
  --timeout=1h \
  --poll-interval=15s \
  --dir-cache-time=1000h \
  --cache-dir=/media/ssd/rclone_cache_ftp \
  --vfs-cache-mode=full \
  --vfs-cache-max-size=1G \
  --vfs-cache-max-age=12h \
  unionmount: /data1/unionmount
ExecStop=/bin/fusermount -uz /data1/unionmount


The rclone config contents with secrets removed.

type = ftp
host =
user = 
pass = 

type = union
upstreams = /opt/unionmount:ro ftp:

A log from the command with the -vv flag

2023/08/14 18:30:23 INFO  : union root '': poll-interval is not supported by this remote

Maybe this has something to do with it?

FTP is not polling remote so --poll-interval is useless

It is refreshing mount in line with your settings - after 1000h. Remove this flag then it will take up to 5 min to refresh.

Thank you, that worked perfectly!

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.