Rclone to GDrive via Service account reaching storage limit

What is the problem you are having with rclone?

I am currently trying to backup a large amount of files to Google Drive, approximately 1.5 TO. I have configured a service account for it, generated its secret key , and gave it to rclone. Inside one of our Google G Suit account, I have created a folder, gave that folder ID to rclone, and shared it to the service account's email so that it can access it. But once the service account reached 15 Go (default free storage amount), it stopped working, as the files pushed to the folder where seemingly still in the name of the SA, and counting toward its own GDrive limit, instead of our unlimited storage on our domain.

It is unclear to me what has not been configured properly, as I feel like a service account attached to our project on our account pushing files to our drive should also have our unlimited storage.

Otherwise, it absolutely does work, It just hits the storage limit

What is your rclone version (output from rclone version)

rclone v1.52.2

  • os/arch: linux/amd64
  • go version: go1.14.4

Which OS you are using and how many bits (eg Windows 7, 64 bit)

Ubuntu 18.04

Which cloud storage system are you using? (eg Google Drive)

Google Drive

The command you were trying to run (eg rclone copy /tmp remote:tmp)

rclone sync /mnt/remote_backup_2/ gdrive:/ -L

A log example

Failed to copy: googleapi: Error 403: The user's Drive storage quota has been exceeded., storageQuotaExceeded

Obviously, repeats for every file.

From command rclone about gdrive:/

Total:   15G
Used:    15.000G
Free:    off
Trashed: 0
Other:   0

So it did use its own gdrive space, instead of our.

From command rclone config show gdrive

type = drive
client_id = {clientid}.apps.googleusercontent.com
client_secret = {secret}
scope = drive
service_account_file = {filepath}/secret.json
root_folder_id = {folderid}

Can someone assist me as to how I should configure this to use our storage instead ?

Thank you

By default a service account uses its own space (each service account has its own email address). This is limited to 15G as you've discovered.

I think that using --drive-impersonate or set the impersonate config flag to make it use the config of a user will fix it.

1 Like

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.