Rclone to GDrive to Plex - Plex charging on high bitrates streaming

Yes, I did a reset of my computer -> it worked. Now I can watch 4K REMUX in a second :smiley:

Hello thanks for welcoming me!
So I'm trying to explain it a little bit better now:

I'm trying to play a video that has a higher bitrate as the 25-30Mbit/s-ish that the server (VPS) is sending to my local Plex Player. Therefore it is buffering every few seconds and makes it unwatchable. I don't know what is limiting me here.

Rclone streams the file from Google Drive to the server with the full bandwidth as it should be, but then the server is only sending me the above mentioned 25-30Mb/s to my local PC. Even though I could get around 100Mb/s to my local Plex Player and the server has and 1Gb/s upload as well..?

You can check this out, I gave more information on reddit.

so the problem is not with rclone itself?

that the problem is between the plex server hosted on a vps and the plex player?

I'm shook.. You are right I think. I tried to upload a video to YouTube using the VPS and it used its upload bandwidth like it should. Then I played a video with a higher bitrate that was on the drive of the VPS and I got the same speeds as with one that was on Google Drive... I really don't know what I can do anymore.. I looked up the internal settings of the Plex Media Server if I had set any limits for uploading but found nothing that could limit it. :frowning:

Thank you for your reddit post. I tried to test my connection with that of the VPS via iperf3 like you did and surely enough I got almost the exact same results as you did.. Now I really don't want to reset the server or my computer either, so I will have to try out other things may could help me with this problem.. :confused:

is that computer running plex player, windows or linux?

I use Windows 10 x64 2004 and the server runs Debian 10 x64. I even tested downloading a file with FTP from the server to my PC and even there I get the strange ~30Mb/s limit but per file and with Plex it is per stream.. I don't know whats wrong and can't find any solution what that weird invisible limit is? :frowning:

on win10, can you post the output of
netsh interface tcp show global

I hope it doesn't bother you that it is in German.. :smiley:

netsh interface tcp show global

Der aktive Status wird abgefragt...

Globale TCP-Parameter

Zustand der empfangsseitigen Skalierung : disabled
Autom. Abstimmungsgrad Empfangsfenster : disabled
Add-On "Überlastungssteuerungsanbieter" : default
ECN-Funktion : disabled
RFC 1323-Zeitstempel : disabled
RTO (anfänglich) : 1000
Zustand der Empfangssegmentzusammenfügung : enabled
Nicht-SACK-RTT-Widerstandsfähigkeit : disabled
Maximale SYN-Neuübertragungen : 4
Fast Open : enabled
Fast Open-Fallback : enabled
HyStart : enabled
Proportionale Ratenreduzierung : enabled
Schrittsteuerungsprofil : off

which one is autotuninglevel

Autom. Abstimmungsgrad Empfangsfenster : disabled

try this, sometimes a reboot is needed.
netsh int tcp set global autotuninglevel=normal

Okay I changed it and will reboot now, but what does it do, and how could this solve the problem? :o

take a read of this

as a test, you can run rclone mount on the windows computer and using vlc, play media.
also, easy to run plex server on win10

Oh my god! Thank you very very much that did it! I get the full ~100 Mbit/s that my local connection is capable in terms of download speed from the server! I didn't even need to test it locally with rclone mount because I directly got the full speed from the server! :smiley:

happy to help a fellow rcloner on a happy new years day.
the crazy thing is, this post and the previous post, back to back posts, were both solved with that same netsh command

the only thing missing from this post is another like from @VBB....

1 Like

You rang?? :heart_eyes:

How come this is not set to "normal" for so many users? Did you all mess with it, use some kind of optimizer or something? All my installations have this set to "normal" by default... :stuck_out_tongue:

Happy New Year, btw! :partying_face:

...and try finding a word as long as Empfangssegmentzusammenfügung in the English dictionary! We Germans are a bunch of cunning linguists :innocent:

i assume you have read the original post, so i will delete it now...

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.