Rclone Systemd mount with MergerFS GoogleDrive Error

Hey there So I been stuck with my problem for a day now and tried many things spent like 6 hours trying to fix this but no luck so I hope someone can help me down here.

I am trying to create a systemd for rclone as a service but it just never starts, keep giving me error also note I am not quite experienced with rclone I mean I use it most of the time for uploading and downloading file to google drive. below is my configuration for the rclone-vfs.service

Description=RClone VFS Service


ExecStart=/home12/kaiserbh/bin/rclone mount gdrive: /home12/kaiserbh/stuff/mount \
		--allow-other \
		--config /home12/kaiserbh/.config/rclone/rclone.conf \
		--use-mmap \
		--drive-skip-gdocs \
		--dir-cache-time 168h \
		--log-level DEBUG \
		--log-file= /home12/kaiserbh/scripts/rclone.log \
		--timeout 1h \
		--umask 002 \
		--poll-interval=1m \
		--vfs-cache-mode writes \
		--vfs-read-chunk-size 64M \
		--vfs-read-chunk-size-limit 2048M
ExecStop=/bin/fusermount -uz /home12/kaiserbh/stuff/mount


The Erro I am receiving are

Job for rclone-vfs.service failed because the control process exited with error code.
See "systemctl --user status rclone-vfs.service" and "journalctl --user -xe" for details.

Then when i try to systemctl --user status rclone-vfs.service

rclone-vfs.service - RClone VFS Service
   Loaded: loaded (/home12/kaiserbh/.config/systemd/user/rclone-vfs.service; enabled; vendor 
   preset: enabled)
   Active: failed (Result: exit-code) since Wed 2019-12-04 08:31:18 CET; 1min 39s ago
   Process: 30867 ExecStart=/home12/kaiserbh/bin/rclone mount gdrive: 
   /home12/kaiserbh/stuff/mount --allow-other--config /home12/kaiserbh/.config/rclone/rclone.conf --use-mmap --drive-skip-gdocs --dir-cache-time 168h --log-level DEBUG --log-file= /home12/kaiserbh/scripts/rclone.log --timeout 1h --umask 002 --poll-interval=1m --vfs-cache-mode writes --vfs-read-chunk-size 64M --vfs-read-chunk-size-limit 2048M (code=exited, status=1/FAILURE)
   Main PID: 30867 (code=exited, status=1/FAILURE)

If anyone call help me with this I'd appriciate it thanks in advance.

Try without space after the = sign

If that doesn't work, please post the contents of the log file

Tried without the space even and still no log file nothing written out in the folder, also tried using ~/scripts/rclone.log \ still not working also i want to apologize for the late reply i didn't get any notification until today when i checked it :slight_smile:

Have you tried to run the command manually with -vv and see what rclone output is?

No I haven't I will try it and get back :slight_smile: