Rclone Sync - Trying to resync everything again


Is there a way to have rclone “check” files that need to be synced based on size alone?

Longer Version:
I recently got snapraid setup on my local media server. When I went to check the status, it told me there were ~1400 files that had a sub-zero timestamp and that I needed to run the command “touch” on all of them to generate the timestamp.

So I just ran a quick command on the terminal to “touch” all of my media files. What I should have done is run “snapraid touch” as it knows the appropriate files and it only updates those that need to be.

So now rclone is seeing all new files because the hash is different and it’s trying to upload everything again when I run my nightly sync. And since google limits you to 750Mb/day, the process has been running for DAYS…

Since the files aren’t actually different, is there a way to tell sync “hey, these are all still good” or do I just need to let it run it’s course?

–size-only will tell rclone to look only for size when checking if the files are the same.
Not sure if there’s some option to update the timestamps from one remote to another (for sure not all remotes even support updating the timestamps).

That is the right thing for the moment if you don’t want to actually sync the files.

There isn’t yet, but it is in discussion :slight_smile: